bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[browser]Can't scroll to text entry box, on Mibbit / CGI:IRC

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Browser
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({b2g-testdriver, unagi})

unspecified
x86_64
Linux
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Reporter)

Description

6 years ago
STR:
 1. Visit http://landfill.bugzilla.org/irc/

 2. In the "Channel" field, type in a random channel where you won't bother anyone (e.g. "#qqqwww"), and hit "Login" button

    --> You're connected to that IRC channel

 3. Try to type stuff into IRC

ACTUAL RESULTS: I can't focus the input textbox.  Sometimes it's offscreen, and if I try to scroll down to it, focus snaps away from it. And even when it's on-screen, tapping it seems to have no effect. (on-screen keyboard doesn't appear)
(Reporter)

Comment 1

6 years ago
I get similar issues at http://chat.mibbit.com, too, FWIW.
We appear to have problems with nested scrollable regions.

If a page is scrollable and contains a scrollable region, if the user puts down the finger in the scrollable region he can *only* scroll that scrollable region.

This happens even if the scrollable region can only scroll up/down whereas the user is trying to scroll the page left/right.

Could that be the problem here?

It's often very unclear that part of the page is scrollable, which means that it can be very unclear why the page isn't scrolling when you move around the finger.

What we *should* do IMHO is if you put your finger in a scrollable region which is scrolled all the way to the right, and then move your finger further to the right, we should scroll any parent scrollable region which isn't scrolled all the way to the right. Until that region reaches the right-most edge at which point we'd scroll the next parent and so on.

This made gmail completely unusable to me until I found some pixels on the edge which weren't scrollable and which let me scroll the page itself.
blocking-basecamp: --- → ?
I'm not sure that comment 0 and comment 2 are describing the same things.  Comment 0 sounds like issues with URL bar auto-hiding, which have been mitigated in the latest stable build somewhat.  Comment 2 is describing the intended behavior of our "sync scrolling" fallback.  If that's not happening, it's "just a bug" ;).
I'm not sure what's going on here. If it's a problem with the URL bar auto-hiding, why would the keyboard lose focus on the text input?

I'm not ruling that out as a contributing factor, but there seems to be something else going on.
Keywords: qawanted
QA Contact: tchung → nhirata.bugzilla
Yes, sorry, I think comment 2 is something completely different. I filed bug 805638 on that.

Comment 6

6 years ago
If/when this affects more than just Mibbit, we'll reconsider for b-b (please re-nominate). We did bb+ 805638, since it affects a major domain.
blocking-basecamp: ? → -

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.