[socorro-crashstats] Search criteria isn't printed out when no results are found

VERIFIED FIXED

Status

Socorro
Webapp
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: stephend, Assigned: adrian)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

Created attachment 674947 [details]
Screenshot of Django-rewrite

STR:

1. Load http://crash-stats-new-dev.allizom.org/query/?product=Firefox&version=Firefox%3A19.0a1&platform=windows&range_value=14&range_unit=days&date=10%2F25%2F2012+02%3A26%3A43&query_search=signature&query_type=contains&query=libc-2.16.so%400x34fa5&reason=&build_id=20121018030618&process_type=any&hang_type=any#advanced
2. Look at the resulting Query Results message

Expected:

"Results within 14 days of 10/25/2012 02:24:21, where the crash signature contains 'libc-2.16.so@0x34fa5', and the product is one of Firefox, and the version is one of Firefox:19.0a1, and the platform is one of Windows for build 20121018030618 and the crashing process was of any type (including unofficial release channels).

No results were found."

Actual:

"No results were found."
Summary: [socorro-crashstats] buildid isn't printed out in search results → [socorro-crashstats] Search criteria isn't printed out when no results are found
(Assignee)

Updated

6 years ago
Assignee: nobody → adrian
(Assignee)

Updated

6 years ago
Duplicate of this bug: 805768

Comment 3

6 years ago
Commits pushed to master at https://github.com/mozilla/socorro-crashstats

https://github.com/mozilla/socorro-crashstats/commit/86a33dffe6da5eb71739107c933651d3d3fd9a66
Fixes bug 805316 - Fixed parameters test to decide whether a search is run or not.

https://github.com/mozilla/socorro-crashstats/commit/ec649039258916aba6aa9ed8c2df5fcdfb639bb4
Merge pull request #232 from AdrianGaudebert/805316-query-show-criterias

Fixes bug 805316 - Fixed parameters test to decide whether a search is r...

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Created attachment 675596 [details]
Post-fix screenshot
Verified FIXED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.