Bug 805379 (bsod)

"app://system... not found" error page after applying update

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: cjones, Assigned: fabrice)

Tracking

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

There's probably no way I'll ever reproduce this, but here's what happened
 (1) Download and apply 10-24 stable update
 (2) "Install" (restart b2g)

What came up was the infamous blue error screen of failed load of the phone.

Rebooting made that go away :/.

I was in the middle of several things at once, so like a fool I forgot to grab logcat.  ARGH!!!
blocking-basecamp: ? → +
Priority: -- → P2
Jason, can you try to reproduce this?
QA Contact: jsmith
I've seen this, but not related to doing an update, but just starting up the phone.

I'm wondering if this has something to do with the state of Wifi/3G (i.e. data connection).

I have a feeling that at some point something trys to reach out to the network to get something and perhaps some types of errors cause it fall back to what's cached on the phone and other types of errors cause it to display the error screen.

In the cases I saw it, I had my GAIA_DOMAIN set to a non-existant domain name (back when GAIA_DOMAIN was still supported/used)
Created attachment 675247 [details]
adb logcat while phone stuck at orange splash

Joe downloaded and applied the 10-24 stable update and rebooted.  He ended up with his Unagi sitting at the "FirefoxOS" splash screen.  adb logcat is attached.  The final stanza regarding the camera just repeats if I let logcat go.  It seems different than cjones' issue so just say so if you'd rather another bug be filed.
Eep.  Yeah, that looks different, and scarier :(.
I "bricked" my unagi the first time I downloaded by accidentally downloading an otoro image. Probably not related, but I figured it was worth mentioning.
Sending this over to Tony since he's been driving the testing of OTA updates.
QA Contact: jsmith → tchung
I regularly get this 'blue screen' after flashing my PandaBoard. Rebooting makes the problem go away. Here is the logcat. The line

> E/GeckoConsole( 1237): [JavaScript Error: "this.webapps[msg.id] is undefined" {file: "resource://gre/modules/Webapps.jsm" line: 602}]

looks suspicious.

>>>>>

[tdz@host-6-53 B2G-panda]$ adb logcat
--------- beginning of /dev/log/main
I/DEBUG   ( 1240): debuggerd: Oct 30 2012 15:21:40
E/uim-sysfs( 1235): uim: Inside main
E/uim-sysfs( 1235): uim:ST built into the kernel ?
E/uim-sysfs( 1235): uim:BT driver module un-available... 
E/uim-sysfs( 1235): uim:BT driver built into the kernel ?
E/uim-sysfs( 1235): uim:FM driver module un-available... 
E/uim-sysfs( 1235): uim:FM driver built into the kernel ?
E/uim-sysfs( 1235): uim:GPS driver module un-available... 
E/uim-sysfs( 1235): uim:GPS driver built into the kernel ?
E/uim-sysfs( 1235): uim:FM V4L2 driver module un-available... 
E/uim-sysfs( 1235): uim:FM V4L2 driver built into the kernel ?
E/uim-sysfs( 1235): uim:found bluetooth rfkill entry @ 0
E/uim-sysfs( 1235): 
E/uim-sysfs( 1235): uim:changed permissions for /sys/class/rfkill/rfkill0/state(0) 
E/uim-sysfs( 1235): 
E/uim-sysfs( 1235): uim:install already set
E/uim-sysfs( 1235): uim: Inside st_uart_config
E/uim-sysfs( 1235): uim:install set to 1
E/uim-sysfs( 1235): uim:opening /dev/ttyO1, while already open
E/uim-sysfs( 1235): uim:cleanup
E/uim-sysfs( 1235): uim: Inside set_baud_rate
E/uim-sysfs( 1235): uim: set_baud_rate() done
E/uim-sysfs( 1235): uim: Setting speed to 3686400
E/uim-sysfs( 1235): uim: Inside read_command_complete
E/uim-sysfs( 1235): uim: Command complete started
E/uim-sysfs( 1235): uim: Inside read_hci_event
E/uim-sysfs( 1235): uim: read_hci_event
E/uim-sysfs( 1235): uim: Command complete done
E/uim-sysfs( 1235): uim: Speed changed to 3686400
E/uim-sysfs( 1235): uim: Inside set_custom_baud_rate
E/uim-sysfs( 1235): uim: Changing baud rate to 3686400, flow control to 1
E/uim-sysfs( 1235): uim: set_custom_baud_rate() done
E/uim-sysfs( 1235): uim: Installed N_TI_WL Line displine
D/DHCP    ( 1248): ===== DHCP message:
D/DHCP    ( 1248): op = BOOTREQUEST (1), htype = 1, hlen = 6, hops = 0
D/DHCP    ( 1248): xid = 0x11390000 secs = 0, flags = 0x8000 optlen = 14
D/DHCP    ( 1248): ciaddr = 0.0.0.0
D/DHCP    ( 1248): yiaddr = 0.0.0.0
D/DHCP    ( 1248): siaddr = 0.0.0.0
D/DHCP    ( 1248): giaddr = 0.0.0.0
D/DHCP    ( 1248): chaddr = { 2e  60  d3  3e  4e  01 }
D/DHCP    ( 1248): sname = ''
D/DHCP    ( 1248): file = ''
D/DHCP    ( 1248): op 53 len 1 { 01 } discover
D/DHCP    ( 1248): op 55 len 4 { 01  03  06  1c } 
I/Netd    ( 1239): Netd 1.0 starting
--------- beginning of /dev/log/system
I/Vold    ( 1232): Vold 2.1 (the revenge) firing up
E/Vold    ( 1232): Error reading configuration (No such file or directory)... continuing anyways
I/        ( 1243): ServiceManager: 0xced910
E/uim-sysfs( 1235): uim: Inside st_uart_config
E/uim-sysfs( 1235): uim: Un-Installed N_TI_WL Line displine
E/uim-sysfs( 1235): uim:cleanup
I/        ( 1244): ServiceManager: 0x1b01958
I/AudioFlinger( 1244): Loaded primary audio interface from OMAP4 audio HW HAL (audio)
I/AudioFlinger( 1244): Using 'OMAP4 audio HW HAL' (audio.primary) as the primary audio interface
I/AudioFlinger( 1244): Loaded a2dp audio interface from A2DP Audio HW HAL (audio)
I/CameraService( 1244): CameraService started (pid=1244)
I/AudioFlinger( 1244): AudioFlinger's thread 0x1b07fe8 ready to run
W/AudioFlinger( 1244): Thread AudioOut_1 cannot connect to the power manager service
W/AudioFlinger( 1244): Thread AudioOut_1 cannot connect to the power manager service
I/AudioPolicyService( 1244): Loaded audio policy from LEGACY Audio Policy HAL (audio_policy)
D/DHCP    ( 1248): TIMEOUT
D/DHCP    ( 1248): ===== DHCP message:
D/DHCP    ( 1248): op = BOOTREQUEST (1), htype = 1, hlen = 6, hops = 0
D/DHCP    ( 1248): xid = 0x11390000 secs = 0, flags = 0x8000 optlen = 14
D/DHCP    ( 1248): ciaddr = 0.0.0.0
D/DHCP    ( 1248): yiaddr = 0.0.0.0
D/DHCP    ( 1248): siaddr = 0.0.0.0
D/DHCP    ( 1248): giaddr = 0.0.0.0
D/DHCP    ( 1248): chaddr = { 2e  60  d3  3e  4e  01 }
D/DHCP    ( 1248): sname = ''
D/DHCP    ( 1248): file = ''
D/DHCP    ( 1248): op 53 len 1 { 01 } discover
D/DHCP    ( 1248): op 55 len 4 { 01  03  06  1c } 
E/profiler( 1237): Registering start signal
D/DHCP    ( 1248): ===== DHCP message:
D/DHCP    ( 1248): op = BOOTREPLY (2), htype = 1, hlen = 6, hops = 0
D/DHCP    ( 1248): xid = 0x11390000 secs = 0, flags = 0x8000 optlen = 312
D/DHCP    ( 1248): ciaddr = 0.0.0.0
D/DHCP    ( 1248): yiaddr = 192.168.178.33
D/DHCP    ( 1248): siaddr = 192.168.178.1
D/DHCP    ( 1248): giaddr = 0.0.0.0
D/DHCP    ( 1248): chaddr = { 2e  60  d3  3e  4e  01 }
D/DHCP    ( 1248): sname = ''
D/DHCP    ( 1248): file = ''
D/DHCP    ( 1248): op 53 len 1 { 02 } offer
D/DHCP    ( 1248): op 54 len 4 { c0  a8  b2  01 } 
D/DHCP    ( 1248): op 51 len 4 { 00  0d  2f  00 } 
D/DHCP    ( 1248): op 58 len 4 { 00  06  97  80 } 
D/DHCP    ( 1248): op 59 len 4 { 00  0b  89  20 } 
D/DHCP    ( 1248): op 1 len 4 { ff  ff  ff  00 } 
D/DHCP    ( 1248): op 3 len 4 { c0  a8  b2  01 } 
D/DHCP    ( 1248): op 6 len 4 { c0  a8  b2  01 } 
D/DHCP    ( 1248): op 15 len 9 {fritz.box} 
D/DHCP    ( 1248): op 28 len 4 { c0  a8  b2  ff } 
D/DHCP    ( 1248): --- dhcp offer (2) ---
D/DHCP    ( 1248): ip 192.168.178.33 gw 192.168.178.1 prefixLength 24
D/DHCP    ( 1248): dns1: 192.168.178.1
D/DHCP    ( 1248): server 192.168.178.1, lease 864000 seconds
D/DHCP    ( 1248): ===== DHCP message:
D/DHCP    ( 1248): op = BOOTREQUEST (1), htype = 1, hlen = 6, hops = 0
D/DHCP    ( 1248): xid = 0x12390000 secs = 0, flags = 0x8000 optlen = 26
D/DHCP    ( 1248): ciaddr = 0.0.0.0
D/DHCP    ( 1248): yiaddr = 0.0.0.0
D/DHCP    ( 1248): siaddr = 0.0.0.0
D/DHCP    ( 1248): giaddr = 0.0.0.0
D/DHCP    ( 1248): chaddr = { 2e  60  d3  3e  4e  01 }
D/DHCP    ( 1248): sname = ''
D/DHCP    ( 1248): file = ''
D/DHCP    ( 1248): op 53 len 1 { 03 } request
D/DHCP    ( 1248): op 55 len 4 { 01  03  06  1c } 
D/DHCP    ( 1248): op 50 len 4 { c0  a8  b2  21 } 
D/DHCP    ( 1248): op 54 len 4 { c0  a8  b2  01 } 
D/DHCP    ( 1248): ===== DHCP message:
D/DHCP    ( 1248): op = BOOTREPLY (2), htype = 1, hlen = 6, hops = 0
D/DHCP    ( 1248): xid = 0x12390000 secs = 0, flags = 0x8000 optlen = 312
D/DHCP    ( 1248): ciaddr = 0.0.0.0
D/DHCP    ( 1248): yiaddr = 192.168.178.33
D/DHCP    ( 1248): siaddr = 192.168.178.1
D/DHCP    ( 1248): giaddr = 0.0.0.0
D/DHCP    ( 1248): chaddr = { 2e  60  d3  3e  4e  01 }
D/DHCP    ( 1248): sname = ''
D/DHCP    ( 1248): file = ''
D/DHCP    ( 1248): op 53 len 1 { 05 } ack
D/DHCP    ( 1248): op 54 len 4 { c0  a8  b2  01 } 
D/DHCP    ( 1248): op 51 len 4 { 00  0d  2f  00 } 
D/DHCP    ( 1248): op 58 len 4 { 00  06  97  80 } 
D/DHCP    ( 1248): op 59 len 4 { 00  0b  89  20 } 
D/DHCP    ( 1248): op 1 len 4 { ff  ff  ff  00 } 
D/DHCP    ( 1248): op 3 len 4 { c0  a8  b2  01 } 
D/DHCP    ( 1248): op 6 len 4 { c0  a8  b2  01 } 
D/DHCP    ( 1248): op 15 len 9 {fritz.box} 
D/DHCP    ( 1248): op 28 len 4 { c0  a8  b2  ff } 
D/DHCP    ( 1248): --- dhcp ack (5) ---
D/DHCP    ( 1248): ip 192.168.178.33 gw 192.168.178.1 prefixLength 24
D/DHCP    ( 1248): dns1: 192.168.178.1
D/DHCP    ( 1248): server 192.168.178.1, lease 864000 seconds
D/DHCP    ( 1248): configuring eth0
I/Gonk    ( 1237): Socket open for RIL
I/VolumeManager( 1237): changing state from 'Uninitialized' to 'Starting'
I/VolumeManager( 1237): Connected to vold
I/VolumeManager( 1237): changing state from 'Starting' to 'Volumes Ready'
D/VoldCmdListener( 1232): volume list
I/AutoMounter( 1237): UpdateState: umsAvail:1 umsEnabled:0 mode:0 usbCablePluggedIn:1 tryToShare:0
I/AutoMounter( 1237): UpdateState: Volume sdcard is Init and inserted
I/Gonk    ( 1237): Connected to netd
E/EventHub( 1237): could not get driver version for /dev/input/mice, Not a typewriter
E/GonkSensor( 1237): Can't get sensor HAL module
D/EventHub( 1237): No input device configuration file found for device 'Panda Headset Jack'.
I/EventHub( 1237): New device: id=1, fd=37, path='/dev/input/event1', name='Panda Headset Jack', classes=0x80, configuration='', keyLayout='', keyCharacterMap='', builtinKeyboard=false
D/EventHub( 1237): No input device configuration file found for device 'gpio-keys'.
I/power   ( 1237): *** set_screen_state 1
I/EventHub( 1237): New device: id=2, fd=38, path='/dev/input/event0', name='gpio-keys', classes=0x1, configuration='', keyLayout='/system/usr/keylayout/gpio-keys.kl', keyCharacterMap='/system/usr/keychars/Generic.kcm', builtinKeyboard=false
I/InputReader( 1237): Device added: id=2, name='gpio-keys', sources=0x00000101
I/InputReader( 1237): Device added: id=1, name='Panda Headset Jack', sources=0x80000000
E/GeckoConsole( 1237): [JavaScript Warning: "Unknown property 'align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
E/GeckoConsole( 1237): [JavaScript Warning: "Unknown property 'order'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 45}]
I/FMRadio ( 1237): FMRadio is initialized.
I/GeckoDump( 1237): Opened socket on 9999
W/AudioFlinger( 1244): Thread AudioOut_1 cannot connect to the power manager service
I/Gecko   ( 1237): [AccessFu] INFO attach
E/GeckoConsole( 1237): [JavaScript Error: "this.webapps[msg.id] is undefined" {file: "resource://gre/modules/Webapps.jsm" line: 602}]
I/Gecko   ( 1237): Logging GL tracing output to /system/b2g/firefox.trace
I/Gecko   ( 1237): Attempting load of /data/local/egltrace.so
I/Gecko   ( 1237): Attempting load of libEGL.so
D/libEGL  ( 1237): loaded /system/lib/egl/libGLES_android.so
D/libEGL  ( 1237): loaded /vendor/lib/egl/libEGL_POWERVR_SGX540_120.so
D/libEGL  ( 1237): loaded /vendor/lib/egl/libGLESv1_CM_POWERVR_SGX540_120.so
D/libEGL  ( 1237): loaded /vendor/lib/egl/libGLESv2_POWERVR_SGX540_120.so
I/ti_hwc  ( 1237): clone region is set to (0,0) to (1280,720)
D/ti_hwc  ( 1237): #0: 640x480 59Hz
D/ti_hwc  ( 1237): #1: 640x480 75Hz
D/ti_hwc  ( 1237): #2: 800x600 60Hz
D/ti_hwc  ( 1237): #3: 800x600 75Hz
D/ti_hwc  ( 1237): #4: 1024x768 60Hz
D/ti_hwc  ( 1237): #5: 1024x768 75Hz
D/ti_hwc  ( 1237): #6: 1280x1024 75Hz
D/ti_hwc  ( 1237): #7: 1152x864 75Hz
D/ti_hwc  ( 1237): #8: 1280x960 60Hz
D/ti_hwc  ( 1237): #9: 1280x1024 60Hz
D/ti_hwc  ( 1237): picking #0
I/ti_hwc  ( 1237): external display changed (state=1, mirror={enabled tform=0deg}, dock={enabled tform=0deg}, tv=1
I/ti_hwc  ( 1237): omap4_hwc_device_open(rgb_order=1 nv12_only=0)
E/GeckoConsole( 1237): OpenGL LayerManager Initialized Succesfully.
E/GeckoConsole( 1237): Version: OpenGL ES 2.0 build 1.8@785978
E/GeckoConsole( 1237): Vendor: Imagination Technologies
E/GeckoConsole( 1237): Renderer: PowerVR SGX 540
E/GeckoConsole( 1237): FBO Texture Target: TEXTURE_2D
E/EventHub( 1237): could not get driver version for /dev/input/mouse0, Not a typewriter
D/EventHub( 1237): No input device configuration file found for device 'Logitech USB-PS/2 Optical Mouse'.
I/EventHub( 1237): New device: id=3, fd=84, path='/dev/input/event2', name='Logitech USB-PS/2 Optical Mouse', classes=0x80000008, configuration='', keyLayout='', keyCharacterMap='', builtinKeyboard=false
I/InputReader( 1237): Device added: id=3, name='Logitech USB-PS/2 Optical Mouse', sources=0x00002002
I/IdleService( 1237): Registering Idle observer callback
I/IdleService( 1237): Register idle observer 47e6d510 for 180 seconds
I/IdleService( 1237): Register: adjusting next switch from -1 to 180 seconds
I/IdleService( 1237): next timeout 1351632008439514 usec (180000 msec from now)
I/IdleService( 1237): SetTimerExpiryIfBefore: next timeout 1351632008439514 usec
I/IdleService( 1237): reset timer expiry from 0 usec to 1351632008449514 usec
D/NetUtils( 1237): failed to remove default route for wlan0: No such process
E/profiler( 1375): Registering start signal
E/GeckoConsole( 1375): [JavaScript Warning: "Unknown property 'align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
E/GeckoConsole( 1375): [JavaScript Warning: "Unknown property 'order'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 45}]
E/GeckoConsole( 1237): [JavaScript Warning: "Unknown property 'align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
E/GeckoConsole( 1237): [JavaScript Warning: "Unknown property 'order'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 45}]
D/wpa_supplicant( 1384): wpa_supplicant v0.8.x
D/wpa_supplicant( 1384): random: Trying to read entropy from /dev/random
D/wpa_supplicant( 1384): Initializing interface 'wlan0' conf '/data/misc/wifi/wpa_supplicant.conf' driver 'nl80211' ctrl_interface 'N/A' bridge 'N/A'
D/wpa_supplicant( 1384): Configuration file '/data/misc/wifi/wpa_supplicant.conf' -> '/data/misc/wifi/wpa_supplicant.conf'
D/wpa_supplicant( 1384): Reading configuration file '/data/misc/wifi/wpa_supplicant.conf'
D/wpa_supplicant( 1384): update_config=1
D/wpa_supplicant( 1384): ctrl_interface='wlan0'
D/wpa_supplicant( 1384): ap_scan=1
D/wpa_supplicant( 1384): fast_reauth=1
D/wpa_supplicant( 1384): nl80211: interface wlan0 in phy phy0
I/wpa_supplicant( 1384): rfkill: Cannot open RFKILL control device
D/wpa_supplicant( 1384): nl80211: RFKILL status not available
D/wpa_supplicant( 1384): netlink: Operstate: linkmode=1, operstate=5
D/wpa_supplicant( 1384): nl80211: Using driver-based off-channel TX
D/wpa_supplicant( 1384): nl80211: driver param='(null)'
D/wpa_supplicant( 1384): wpa_driver_nl80211_set_key: ifindex=7 alg=0 addr=0x0 key_idx=0 set_tx=0 seq_len=0 key_len=0
D/wpa_supplicant( 1384): wpa_driver_nl80211_set_key: ifindex=7 alg=0 addr=0x0 key_idx=1 set_tx=0 seq_len=0 key_len=0
D/wpa_supplicant( 1384): wpa_driver_nl80211_set_key: ifindex=7 alg=0 addr=0x0 key_idx=2 set_tx=0 seq_len=0 key_len=0
D/wpa_supplicant( 1384): wpa_driver_nl80211_set_key: ifindex=7 alg=0 addr=0x0 key_idx=3 set_tx=0 seq_len=0 key_len=0
D/wpa_supplicant( 1384): nl80211: Flush PMKIDs
D/wpa_supplicant( 1384): WPS: Set UUID for interface wlan0
D/wpa_supplicant( 1384): EAPOL: SUPP_PAE entering state DISCONNECTED
D/wpa_supplicant( 1384): EAPOL: Supplicant port status: Unauthorized
D/wpa_supplicant( 1384): EAPOL: KEY_RX entering state NO_KEY_RECEIVE
D/wpa_supplicant( 1384): EAPOL: SUPP_BE entering state INITIALIZE
D/wpa_supplicant( 1384): EAP: EAP entering state DISABLED
D/wpa_supplicant( 1384): EAPOL: Supplicant port status: Unauthorized
D/wpa_supplicant( 1384): EAPOL: Supplicant port status: Unauthorized
D/wpa_supplicant( 1384): random: Got 20/20 bytes from /dev/random
D/wpa_supplicant( 1384): CTRL_IFACE SET 'pno'='1'
D/wpa_supplicant( 1384): EAPOL: disable timer tick
D/wpa_supplicant( 1384): EAPOL: Supplicant port status: Unauthorized
The line number is slightly different, but this looks like

  receiveMessage: function(aMessage) {
//snip
      case "Webapps:GetBasePath":
        return this.webapps[msg.id].basePath;
        break;

Certainly looks race-condition-y.  Any hypotheses?
(Assignee)

Comment 9

6 years ago
The line difference is due to pre-processing.

Thomas, do you only see this error after a reflash?
I opened the preprocessed .jsm ;).
(In reply to Fabrice Desré [:fabrice] from comment #9)
> The line difference is due to pre-processing.
> 
> Thomas, do you only see this error after a reflash?

Yes, only after flashing. But it's not predictable; sometimes it works.
Note to self, I can reproduce this 100% reliably in the emulator on m-c 01123067aa58 and gaia 6947eedbf2d368e02c1f4dcea6f1f9d958446bb7 .
Alias: bsod
Keywords: qawanted
Fabrice, do you have cycles to grab this?
Milestoning for C2 (deadline of 12/10), as this meets the criteria of "known P2 bugs found before or during C1".
Target Milestone: --- → B2G C2 (20nov-10dec)
Assignee: nobody → fabrice
(Assignee)

Comment 15

6 years ago
Faramarz just handed me an otoro with this issue - it was flashed with today's nightly. When I looked what was on the phone, gaia was not intalled at all! We probably hit some race condition at build time and didn't push gaia. Let's see if the recent fixes to the build system make that disappear.
That's a different symptom than comment 0.  See also comment 12: the bug here reproduces reliably in the emulator.
I can't reproduce in the emulator anymore.

Comment 18

6 years ago
Resolving as per #17, please reopen if anyone can reproduce
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.