Closed Bug 805392 Opened 9 years ago Closed 1 year ago

GIF animation with n loops stops after 1 loop

Categories

(Core :: ImageLib, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: matvey, Unassigned)

Details

Attachments

(1 file)

Attached image testLooped2times.gif
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121023124120

Steps to reproduce:

Created a 2-frame GIF animation that is cycled 2 times (attached) using Adobe Photoshop.


Actual results:

The animation ran only once in Firefox 17 beta, stopping on the second frame.


Expected results:

The animation should have run two times.
This GIF animation runs 2 times in Chrome, Safari on Windows, IE 7-9 (didn't test in IE6).

Opera 12.02 shows the animation only once, similar to Firefox.
Component: Untriaged → ImageLib
Product: Firefox → Core
Version: 17 Branch → Trunk
Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121030030633

I can confirm that the GIF animation runs only once.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reproducible ever since Firefox 4.0, on Windows 7, Ubuntu 12.04 and Mac OS X 10.7.
OS: Windows 7 → All
In Firefox stable 37.0.2, the animation runs indefinitely. I’m also seeing the same in Nightly. Looks like, after 2 and 1/2 years, Firefox’s code for rendering GIFs now displays a different bug.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.