Last Comment Bug 805539 - [B2G] test_geolocation.js often fails on the emulator
: [B2G] test_geolocation.js often fails on the emulator
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla19
Assigned To: Al Tsai [:atsai]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 11:32 PDT by Jonathan Griffin (:jgriffin)
Modified: 2012-11-06 14:02 PST (History)
4 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Prevent affect from default values and network geolocation provider. r=dougt (6.19 KB, patch)
2012-10-30 02:23 PDT, Al Tsai [:atsai]
dougt: review+
Details | Diff | Review
Remove extra whitespace (6.17 KB, patch)
2012-10-30 19:45 PDT, Al Tsai [:atsai]
jgriffin: review+
Details | Diff | Review

Description Jonathan Griffin (:jgriffin) 2012-10-25 11:32:33 PDT
The Marionette WebAPI test test_geolocation.js often fails on the emulator, see e.g,

https://tbpl.mozilla.org/php/getParsedLog.php?id=16458104&tree=Cedar

It will be disabled until this can be fixed, as we're trying to green up the tests so we can move them to m-c, etc.
Comment 1 Jonathan Griffin (:jgriffin) 2012-10-25 11:35:06 PDT
test disabled: https://hg.mozilla.org/mozilla-central/rev/b3b871ca7480
Comment 2 Jonathan Griffin (:jgriffin) 2012-10-25 12:14:27 PDT
also disabled on aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/bdb52de555e1
Comment 3 Jonathan Griffin (:jgriffin) 2012-10-25 14:09:03 PDT
Disabled a little more thoroughly, since manifests with no active tests break tests.zip packaging:  
https://hg.mozilla.org/mozilla-central/rev/3b506ada9ef9
https://hg.mozilla.org/releases/mozilla-aurora/rev/2b2fd1afed3d
Comment 4 Al Tsai [:atsai] 2012-10-30 01:41:05 PDT
Finding:
 The failure could cause by 2 reasons.
 The first one is emulator set a default value and the test script didn't aware it.
 The second one is network geolocation provider could give a value during a test
Comment 5 Al Tsai [:atsai] 2012-10-30 02:23:49 PDT
Created attachment 676519 [details] [diff] [review]
Prevent affect from default values and network geolocation provider. r=dougt

Using stack to avoid default value affect.
Adding disable network provider to avoid network geolocation provider.
It may not be the best way to disable network geolocation provider.
Comment 6 Doug Turner (:dougt) 2012-10-30 12:03:36 PDT
Comment on attachment 676519 [details] [diff] [review]
Prevent affect from default values and network geolocation provider. r=dougt

Review of attachment 676519 [details] [diff] [review]:
-----------------------------------------------------------------

there are more properties that you may want to verify (f.e., heading, altitude, accuracy).  Otherwise lgtm.  You should probably have one of mdas|afk, rwood, jgriffin review too.

::: dom/system/gonk/tests/marionette/test_geolocation.js
@@ +49,4 @@
>    });
> + 
> +  lat  = 0;
> +  lon = 0;   

whitespace

@@ +81,4 @@
>  
> +  cmd = "geo fix " + lon + " " + lat;
> +  sample.push(lat+"/"+lon);
> +  

extra white space
Comment 7 Al Tsai [:atsai] 2012-10-30 19:45:03 PDT
Created attachment 676889 [details] [diff] [review]
Remove extra whitespace
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-11-01 15:47:19 PDT
Comment on attachment 676519 [details] [diff] [review]
Prevent affect from default values and network geolocation provider. r=dougt

Please mark old patches as obsolete. It can be very confusing when you don't.
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-11-01 16:25:19 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/7f8182a28d3f
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-11-02 17:27:53 PDT
https://hg.mozilla.org/mozilla-central/rev/7f8182a28d3f
Comment 11 Jonathan Griffin (:jgriffin) 2012-11-02 17:38:12 PDT
Will land this on aurora after verifying on cedar.
Comment 12 Jonathan Griffin (:jgriffin) 2012-11-06 13:58:16 PST
latest cedar runs are green
Comment 13 Jonathan Griffin (:jgriffin) 2012-11-06 14:02:20 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/22430d341f0f

Note You need to log in before you can comment on or make changes to this bug.