Remove anchor element in the segmented-button for about:reader

RESOLVED DUPLICATE of bug 1120004

Status

()

P4
normal
RESOLVED DUPLICATE of bug 1120004
6 years ago
4 years ago

People

(Reporter: jwir3, Assigned: jwir3)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
The segmented button element (e.g. "Light" and "Dark") has an anchor element in it that could probably be removed. Instead, we could place the text directly in the <li> parent element. Further, we can probably remove the dynamic generation of this element from the aboutReader.js script, and instead, place it directly into the HTML.
The inner anchor element is there because the selected state (different bg color) is smaller than the area of the li element. If you can achieve the same without the anchor element, I'm fine with it.

As for the dynamic generation, this is basically because I wasn't sure how to use translatable strings inside the HTML. Feel free to change it if you know how to do it.

Updated

6 years ago
Priority: -- → P4

Comment 2

4 years ago
I'm fixing this in bug 1120004.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120004
You need to log in before you can comment on or make changes to this bug.