All users were logged out of Bugzilla on October 13th, 2018

The "Set Default..." dialogue after clicking a file link should include the option to "Save to Disk".

VERIFIED FIXED

Status

--
enhancement
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: Peter, Assigned: law)

Tracking

({helpwanted})

Trunk
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9+) Gecko/20010511

"Set Default..." dialogue after clicking file link show should include the
option to "Save to Disk".

I am really tired of Mozilla trying to open or execute some file when all I want
is to *download* the darn thing. This *so-called intelligence* is highly
annoying when I#m not allowed to turn it off.

Does anyone understand how mime types work? I've optimized extended and expanded
memory since DOS 4 and don't have a clue what mime does (actually, how to
configure it). I JUST WANT TO DOWNLOAD THE FILES. I have better programs than
mozilla to handle downloaded files. Anyhow, what do you do once Mozilla has
opened a file in winzip or displayed a jpg on the browser? Then you're forced to
unpack the zip file or re-download the jpg. It's just silly and cumbersome. In
the end, you'll want the file on disk anyhow.

+-----------------------------------------------+
| What should Mozilla do with this type of file |
| <> use default action   [Set Default..]       |  ---->
+-----------------------------------------------+

+- New Type ------------------------------------+
|                                               |
| Description of file [     ]                   |
| file extension      [     ]                   |
| mime type           [     ]                   |
| Application to use  [     ]                   |
|                               [Choose...]     |
+-----------------------------------------------+
|                                               |
| <X> Set default action to "Save file to Disk" | <-- THIS ONE !!!
|                                               |
| < > use this mime for the outgoing type       |
|                                               |
|                           [OK]   [CANCEL]     |
+-----------------------------------------------+
(Reporter)

Updated

18 years ago
Keywords: helpwanted, mozilla0.9.1
(Reporter)

Comment 1

18 years ago
+- Downloading ----------------------------------+
|                                                |
| What should Mozilla do with this type of file  |
|                                                |
| <X> use default action                         |
|    [ Save this file to disk ]  [Set Default..] | <-- THIS IS HOW 
|                                                |     IT SHOULD BE !!!
| < > use a different action                     |
|    < > save this file to disk                  |
|    < > open with application [      ] [choose] |
|                                                |
|                              [ OK ] [Cancel]   |
+------------------------------------------------+

I should be able to JUST hit return (or click on "OK") and be done with it.

Comment 2

18 years ago
->UID
Component: Browser-General → User Interface Design
ccing law -- he wrote the dialog.

I should note that on Linux that _is_ how the dialog comes up -- save to disk is
the default.  This is probably due to us not reading the system mime registry on
Linux.

Peter -- if what you want is save and not open, why are you doing a click? 
would not a shift-click or context menu "save link as" be more appropriate?
Assignee: asa → mpt
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: doronr → zach
(Reporter)

Comment 4

18 years ago
Because most people don't use context menus, and most people don't know about
shift+click (I'm an experienced user and didn't know about it).

Also, people who just want to *save to disk* should be offered the *same level
of convenience* as those who want to display the file ;)
(Assignee)

Comment 5

18 years ago
It seems there are two issues:

1. Do we give preference to the existence of a system-defined "helper app" over
save-to-disk?  I don't think we're likely to change this.  Giving preference to
save-to-disk is just too wrong in too many cases (e.g., Word documents,
streaming audio, etc.).

2. The process of changing the default for a given type to save-to-disk is
harder than it ought to be because the "New Type" dialog doesn't offer a "save
to disk" option.  If it did, then the first time Peter (or other user) saw a
content type, they'd hit the "Set Default..." button, check "save to disk,"
press OK, and be done with it.

Either there is already a bug for item 2, or there should be one (maybe even
this bug could be it, with the right summary and commentary).  Adding Paul Chen
to cc: list (he gets to own the pref New/Edit Type dialogs).
(Reporter)

Comment 6

18 years ago
UMM, I always save M$ word documents to disk first. And saving a streaming audio
clip as a file to disk is also not a bad thing - one can listen to it again and
again without redowloading it.
(Assignee)

Comment 7

18 years ago
And you're certainly welcome to change your default so it works that way.  I
suspect that the majority of users out there can't hardly tell a MS word
document from a web page, is all.
(Reporter)

Comment 8

18 years ago
Well, currently, there is no way to set the "default" to *Save to Disk* for all
filetypes :( That's what I am hoping this bug will fix.

Comment 9

18 years ago
Blake and I will hopefully be taking a pickaxe to the helper apps UI later 
today.

I'll have to look at the details more closely. But given that this basically 
seems to be asking `Do you want me to do what you told me to do, or do you want 
me to do something else?', it's quite possible that the dialog should be gotten 
rid of completely to avoid unnecessary defenestration of hardware.

In any case, you shouldn't use radio buttons for commands. Buttons are for 
commands. Radio buttons are for settings. Just because Microsoft get this wrong 
in the Windows `Shut Down' dialog, that's no excuse for us to get it wrong too.

Comment 10

18 years ago
*** Bug 81647 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
*** Bug 85782 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Summary: "Set Default..." dialogue after clicking file link show should include the option to "Save to Disk" → Set Default..." dialogue after clicking file link show should include the option to "Save to Disk
(Reporter)

Updated

18 years ago
Summary: Set Default..." dialogue after clicking file link show should include the option to "Save to Disk → The "Set Default..." dialogue after clicking a file link should include the option to "Save to Disk".
*** Bug 86245 has been marked as a duplicate of this bug. ***
*** Bug 86335 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
*** Bug 88048 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
See Helper App Dialog Redesign in bug 86640 and bug 88066. Both appear to be 
working on ways to fix this.
Blocks: 78106

Comment 16

18 years ago
Looks like this is fixed (win32, June 28 build) with the new dialog.
nope, the New Type dialog still lacks a "save to disk" choice --whether i access 
it from the pref panel or the "advanced" button in the helper app dialog.

at least, this is the case for me using 2001.06.29.06-trunk commercial bits on 
win98...
perhaps you were accessing the Edit Type dialog instead? [which has "save to 
disk" available as a choice.]

Comment 19

18 years ago
When I click on a link now (in Win2k) it asks if I want to "Open in application"
or "save to disk".  There is also a check box whether I want to be asked this
question again.  Clicking "Save to disk" and unchecking the box (as in "don't
ask") does what I want.  Clicking on files of that type from now on launches a
dialog asking me where I want to put the file.

My opinion is that it now does the Right Thing and this bug should be considered
Resolved/fixed.

Comment 20

18 years ago
Yes, that's what I saw too. I was trying to reproduce it when you posted....
works too well :)
okay, i'm prolly misunderstanding this issue. :)

i've filed another one, bug 88458, which asks to add the "save to disk" choice
to the New Type dialog [not with the helper app/downloading dialog].

Comment 22

16 years ago
.
Assignee: mpt → law
Component: User Interface Design → File Handling
QA Contact: zach → sairuh
QA Contact: sairuh → petersen
fixed by bug 86640.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Depends on: 86640
Resolution: --- → FIXED

Comment 24

16 years ago
Verified in the Win32 2003-01-23-04 and OS X 2003-01-23-03 trunk.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.