If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

400 BAD REQUEST on update of profile page

VERIFIED WORKSFORME

Status

Participation Infrastructure
Phonebook
VERIFIED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Leen Besselink, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
(I might have requested a Mozillians account before, maybe even with the same email address)

Someone vouched for me so I went to the Mozillians site and logged in with BrowserID/Persona.

I was able to add myself to a group, but not able to update my profile (like setting the country) or upload a profile picture (JPEG 10,6 kB 73 x 73px).

So I looked at the Web console in Firefox and noticed I get a HTTP/1.1 400 BAD REQUEST everytime I try to update anything.
(Reporter)

Comment 1

5 years ago
I noticed the code on github.

Line 143 is where the 400 error comes from:

https://github.com/mozilla/mozillians/blob/master/apps/phonebook/views.py

Python isn't my expertise otherwise I might have been able to spot the problem.
(Reporter)

Comment 2

5 years ago
Created attachment 675336 [details]
POST data of the request

This is the POST request as it is sent using a week old Firefox 19 (also tried Firefox 16 and 17).

I've replaced some parts with Xs so I don't leak any information.
(Reporter)

Comment 3

5 years ago
Seems to work now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Leen, Sorry for the delayed response, I'm glad the problem resolved itself for you. Many months ago (7 at least) we had some intermittent problems with accounts and it sounds like your account was one of the ones that fell ill.

We have a new site design landing in production within the next week or so - currently on dev, mozillians-dev.allizom.org - if you find any inconsistencies or have feature suggestions please lend us your voice and file some more bugs.
Status: RESOLVED → VERIFIED

Updated

4 years ago
OS: Linux → All
Hardware: x86_64 → All
You need to log in before you can comment on or make changes to this bug.