[Settings] Un-set "Volume & Tones" volume sliders have the slider all the way at the left, but a blue-highlighted bar going partway across

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({b2g-testdriver, unagi})

unspecified
x86_64
Linux
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:-)

Details

Attachments

(1 attachment)

STR:
 * Go to Settings | Sound
 * Look at the slider under "Volume and Tones"

ACTUAL RESULTS:
It looks like this:
  [O========----------------------]
...where "O" is the slider, "====" is the region highlighted in blue, and "---" is the region un-highlighted in gray.

EXPECTED RESULTS:
It should look like this:
  [========O----------------------]
The slider should be in between the highlighted region and the gray region.
If I manually drag the slider around, then it fixes this and I get EXPECTED RESULTS. But then if I close the Settings app[1] and then re-open it go back to the "Sound" region, I see the bug again.  (slider all the way to the left, and some region of the slide-bar is highlighted in blue)

[1] (by holding down the home button, and then flipping the settings app offscreen
802208
Please Fernando it's a BB issue.
Assignee: nobody → fcampo
blocking-basecamp: ? → -
Two points:
 - This affects the "Brightness" slider in Settings|Display, too.
 - I suspect this may be an instance of bug 807011. (at least, the part about how the slider is always at 0 when I quit settings & re-start it -- not sure about the disagreement between the blue-highlighted-region and the slider-knob, though.)
I've been away for few days and I wonder why exactly
Assignee: fer.campo.garcia → nobody
I've been away few days and I wonder why exactly do I have assigned this one... I'd be happy to help, but I'm sure some other people that has been working with settings could do better :D

Anyway, if this wasn't a mistake as I think it was, I'll take a look asap

Updated

6 years ago
Component: Gaia → Gaia::Settings
This is still broken, FWIW... In today's just-released dogfood build (w/ ID 20121127132302), I saw this on "Alarm", "Notification", and "Content".

Then I hit my physical volume-rocker on the side of the phone, which controls the latter two Notification & Content volume (but not Alarm). This updated the Notification & Content slider-position and moved the "nub" to the correct spot, so that they didn't suffer from this anymore -- but "Alarm" still does, because I haven't modified that one yet.
Summary: [Settings] Volume & Tones volume-slider has the slider all the way at the left, but a blue-highlighted bar going partway across → [Settings] Un-set "Volume & Tones" volume sliders have the slider all the way at the left, but a blue-highlighted bar going partway across
OK, I can't reproduce this anymore after flashing the first "beta" dogfood build ( unagi_beta_2012-12-03.zip ).

Resolving as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.