Closed Bug 805663 Opened 7 years ago Closed 7 years ago

[Browser] Add UA override for Itaú Unibanco (Brazilian bank); desktop website has its right side truncated in B2G browser

Categories

(Core :: Layout, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED DUPLICATE of bug 819210
B2G C4 (2jan on)
blocking-basecamp +

People

(Reporter: gkw, Assigned: lmandel)

References

()

Details

(Keywords: b2g-testdriver, unagi)

Attachments

(3 files)

Attached image screenshot
+++ This bug was initially created as a clone of Bug #805660 +++

1. Go to http://www.itauunibancoir.com/ - it is a Brazilian bank website.
2. Move to the right. See the edges in the screenshot as circled in red. Parts are truncated.

Works fine on Desktop.

From Wikipedia: "Itaú Unibanco is a Brazilian publicly quoted bank with headquarters in São Paulo, Brazil." - https://en.wikipedia.org/wiki/Ita%C3%BA_Unibanco

===

My Git commit info currently shows:

2012-10-24 11:07:05
fcfa1857bed6596e992263206451c6814e4b2... (I see ellipsis at the end)
Hardware: x86 → ARM
Component: Gaia → General
Keywords: qawanted
Jet, can someone on the Layout team take a look?
blocking-basecamp: ? → +
Component: General → Layout
Product: Boot2Gecko → Core
Firefox for Android 2012-10-30 nightly seems to work fine with the mobile version of the site being served.
I can confirm with 2012-10-31 B2G build (came in as an OTA update today) that I'm still getting the desktop version and the things are cut off at the bottom.  Kats tried it on desktop with a 980 pixel wide viewport and in there he can scroll horizontally.  I can't scroll horizontally on my Unagi.
jet, can we find an owner for this investigation?
Assignee: nobody → bugs
Has someone tried testing this on FF Android with a FF OS user agent? That will help rule out if this is a user agent issue.
Firefox for Android gets mobile content.  UA override, Lawrence?
Flags: needinfo?(lmandel)
Priority: -- → P1
Yes please.
Flags: needinfo?(lmandel)
Summary: [Browser] Itaú Unibanco (Brazilian bank) website has its right side truncated in B2G browser → [Browser] Add UA override for Itaú Unibanco (Brazilian bank); desktop website has its right side truncated in B2G browser
Assignee: bugs → bjacob
Keywords: qawanted
Do we know our criteria for at what point we would decide that we should always have Android in the UA string?
Attachment #687511 - Flags: review?(poirot.alex)
Comment on attachment 687511 [details] [diff] [review]
Add UA override for Itaú Unibanco

The website redirects to: 
  http://ww13.itau.com.br/portalri/index.aspx?idioma=ing&AspxAutoDetectCookieSupport=1
So that the override doesn't really work.
Attachment #687511 - Flags: review?(poirot.alex) → review-
(In reply to Benoit Jacob [:bjacob] from comment #8)
> Created attachment 687511 [details] [diff] [review]
> Add UA override for Itaú Unibanco
> 
> Do we know our criteria for at what point we would decide that we should
> always have Android in the UA string?

+1
Or Firefox Mobile UA?
At this rate the ua-override file will contain the whole web :o
Random websites are being added into it. it goes from maps.google to brazilian bank website...
(In reply to Alexandre Poirot (:ochameau) from comment #10)
> At this rate the ua-override file will contain the whole web :o
> Random websites are being added into it. it goes from maps.google to
> brazilian bank website...

It may appear random but we're being deliberate about the sites that are applicable for the UA override list. jjensen is working to come up with a answer for the list of sites in a target locale that cover the X% use case. (The sites that are used in, say, 70% of browsing sessions.) In the absence of this data, we are working off of a more simplistic model that says that the top 100 sites (as determined by Alexa rank) in a locale are candidates for the list. In Brazil, google.com (the Google properties are not broken out by subdomain in Alexa's results) is ranked #3. Banco Itaú is ranked #20.
Comment on attachment 688074 [details] [diff] [review]
Add UA override for Itaú Unibanco, 2 different domains

Doesn't seem to work either.
I'm not sure this website react to a different user agent.
I tried with user agent switcher, it doesn't change when using iphone UA.
Attachment #688074 - Flags: review?(poirot.alex)
Is there anything else I should be doing here or should I un-assign myself?

The problem seems more complex than anticipated and I don't feel very comfortable being the assignee if that's time-sensitive.
(In reply to Alexandre Poirot (:ochameau) from comment #13)
> Comment on attachment 688074 [details] [diff] [review]
> Add UA override for Itaú Unibanco, 2 different domains
> 
> Doesn't seem to work either.
> I'm not sure this website react to a different user agent.
> I tried with user agent switcher, it doesn't change when using iphone UA.

Interesting. I get a mobile site in Firefox for Android Nightly with the default UA testing both itauunibancoir.com and itau.com.br. This makes me think that these overrides *should* work on B2G.
Unassigning myself to reflect reality that I am not working on this at the moment. Let me know if I should be.
Assignee: bjacob → nobody
Mass Modify: All un-milestoned, unresolved blocking-basecamp+ bugs are being moved into the C3 milestone. Note that the target milestone does not mean that these bugs can't be resolved prior to 12/10, rather C2 bugs should be prioritized ahead of C3 bugs.
Target Milestone: --- → B2G C3 (12dec-1jan)
I tested it extensively again and I can't get it to work on device.
The website serve a mobile version on fennec, 
same thing if I use a user agent addon in order to send the user agent this pref should produce:
  Mozilla/5.0 (Android; Mobile; rv:20.0) Gecko/20.0 Firefox/20.0

Dao, It looks like you wrote this override pref. Could you give us some help in debugging that website:
  http://www.itauunibancoir.com/
Do you have any idea why this website wouldn't serve a mobile version when using following pref:
pref("general.useragent.override.itauunibancoir.com", "\(Mobile#(Android; Mobile");
Flags: needinfo?(dao)
Assignee: nobody → lmandel
(In reply to Alexandre Poirot (:ochameau) from comment #18)
> Dao, It looks like you wrote this override pref. Could you give us some help
> in debugging that website:
>   http://www.itauunibancoir.com/
> Do you have any idea why this website wouldn't serve a mobile version when
> using following pref:
> pref("general.useragent.override.itauunibancoir.com", "\(Mobile#(Android;
> Mobile");

If you added the override for all involved domains (e.g. itauunibancoir.com and itau.com.br), then I don't see why it wouldn't work. Maybe the site redirects to a different domain on mobile than it does on desktop?
Flags: needinfo?(dao)
(In reply to Dão Gottwald [:dao] from comment #19)
> If you added the override for all involved domains (e.g. itauunibancoir.com
> and itau.com.br), then I don't see why it wouldn't work. Maybe the site
> redirects to a different domain on mobile than it does on desktop?

That's what we are doing here. We have two overrides: itauunibancoir.com redirects to itau.com.br :/
It is even hard to make it work on desktop with the user agent switcher.
What's the next step here?
I did some digging. This site appears to be performing UA detection in JS by querying navigator.userAgent. (See http://ww13.itau.com.br/PortalRI/HTML/js/detect.js) With the UA override in place, navigator.userAgent still returns the B2G stock UA. Can we modify the B2G browser to make use of the UA override for the value of navigator.userAgent?
Thought I'd add that the behaviour of the domain specific UA override differs from the behaviour of the global UA override. If I globally set the B2G UA to be the Fennec UA navigator.userAgent returns the Fennec UA.
(In reply to Lawrence Mandel [:lmandel] from comment #22)
> Can we modify the
> B2G browser to make use of the UA override for the value of
> navigator.userAgent?

This should already be the case as of bug 800157.
(In reply to Dão Gottwald [:dao] from comment #24)
> (In reply to Lawrence Mandel [:lmandel] from comment #22)
> > Can we modify the
> > B2G browser to make use of the UA override for the value of
> > navigator.userAgent?
> 
> This should already be the case as of bug 800157.

Perhaps this functionality regressed with the change in bug 798694#c19.
I have filed bug 822551 about navigator.userAgent not being affected by a UA override.
Depends on: 822551
Target Milestone: B2G C3 (12dec-1jan) → ---
Target Milestone: --- → B2G C3 (12dec-1jan)
Not clear from the last series of comments - is there anything to do here?
After bug 822551 is fixed we need to add a UA override for this site. However, I think this will be done in bug 819210, which includes the override for itau.com.br. We should leave this open to verify that the override for itau.com.br fixes itauunibancoir.com. We can complete this last step before the other fixes land. I'll try to find time in the next couple of days to do so.
Target Milestone: B2G C3 (12dec-1jan) → B2G C4 (2jan on)
From what I can tell, it does seem that adding the override for itau.com.br will fix itauunibancoir.com. I'm marking this bug as a dup of bug 819210, which includes the override for itau.com.br.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819210
As a follow-up, I verified that the UA override for itau.com.br has fixed itauunibancoir.com.
You need to log in before you can comment on or make changes to this bug.