Clicking link crashes browser

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: bugzilla-f, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Clicking any of the links on this page crashes the browser. It does not crash
when the link is entered manually in the location bar.

Reproduce: go to this (http://www.koolance.com/procuct1.html) page. You may need
to reload it to get moz to display it correctly (bug?). It should display a
computer case, with some parts highlighted. When you move the mouse over a
highlighted part (and you have enabled Javascript, and do not filter out popup()
stuff), a Javascript popup needlessly tells you what it is. Now click on the
part (eg. the CPU). The browser starts loading and displaying the page, but it
crashes somewhere halfway through.

Expected result: It should show the page (in this case:
http://www.koolance.com/Clickable%20Case/largeview/CPUjacket.html)

Observed result: the browser crashes

Other bugs on this page:
 - need to reload the page to get moz to display it
 - context-menu: Copy Link Location does not work, it produces "
An error occurred executing the cmd_copyLink command"

Updated

18 years ago
Severity: normal → critical
Keywords: crash

Comment 1

18 years ago
Everything works for me with 2001051208 / Win98SE:

- Page loads correctly
- Mozilla doesn't crash
- There's no context menu error

Perhaps 0.9 branch only?
(Reporter)

Comment 2

18 years ago
The observed results are from a Linux CVS trunk build

Comment 3

18 years ago
Anyone with a debug build seeing this? Can you compare stacks against bug 80457
and dup this against that if they are the same.

Comment 4

18 years ago
Yes, I have verified this bug on Mozilla 0.9
Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; rv:0.9) Gecko/20010505

Comment 5

18 years ago
Igor, Frank: Can you please download the latest nightly from mozilla.org and
tell us if you still see the crash, and report the build id too. Thanks.
(Reporter)

Comment 6

18 years ago
Just tried it with a freshly downloaded nightly build, build-ID 2001051306

It still crashes...

Last gasp on stderr:

Gdk-CRITICAL **: file gdkwindow.c: line 716 (gdk_window_ref): assertion `window
!= NULL' failed.

In a few other instances, it gave this error just before death:

JavaScript error: 
 line 0: kill is not defined

Comment 7

18 years ago
wfm on SuSE 7.0, build 052706

Comment 8

18 years ago
works on linux rpm build 2001052819

Comment 9

18 years ago
Works for me using linux build 2001060811, and for other recent commenters.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.