Closed Bug 805690 Opened 7 years ago Closed 7 years ago

Opens http URL as https with a 404 error

Categories

(Firefox :: Untriaged, defect)

16 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 769994

People

(Reporter: ronmorgan7, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

Type http://www.sitename.com or www.sitename.com or sitename.com into navigation bar.


Actual results:

It automatically redirects to https://www.sitename.com and a 404 Not Found error. This is only with certain web sites.

After this https URL appears in the navigation bar, I can remove the "s" or the whole "https://" and hit Enter and it goes to the desired http page.

If I include a following / after typing in the URL, it goes to the desired http page.

When entering the URL, it autocompletes with a following /.  If I only type the URL without the / it gets the 404 PNF error.  If I type, then delete, the / it works fine and goes to the http page.


Expected results:

It should never go to https. This is not an https site; it never has been.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
You need to log in before you can comment on or make changes to this bug.