Standalone: Menus which should be removed

VERIFIED DUPLICATE of bug 76247

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 76247
17 years ago
14 years ago

People

(Reporter: Håkan Waara, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
There are a bunch of menus showed in the standalone window, that according to
the spec, should me invisible/removed. I compared with reality and this is the
differences that we need to fix:

(Things wrapped in [] are menus I think should be removed, which are not in the
spec.)

[* File
- Send Unsent Messages
- Import...]

* Edit
- Undo
- Redo
- Cut
- Paste
- Select --->
- Properties...
[- Message Filters...]

* Go
- According to the spec, the whole menu and its items.
(Reporter)

Comment 1

17 years ago
keywords...
Keywords: mailspecui, mozilla1.0, polish, ui

Comment 2

17 years ago
Unfortunately the spec is not up-to-date regarding the navigation issues:
* Go
I think all of these menu items should be available to give users the 
flexibility when navigating between messages.

For users who may spend most of their time in a Stand Alone window, it would be 
convenient for them to also have the option to:

* File
- Send Unsent Messages
- Import

* Edit
- Message Filters

Comment 3

17 years ago
Many of the Edit menu items are already disbled and ideally should be removed. 
These issues are tracked in bug# 76247. I'd like further discussion on the Stand 
Alone menu items to appear in bug# 76247.



*** This bug has been marked as a duplicate of 76247 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
Final note to jglick:

Everybody keeps commenting in my bugs about following the specs "the spec is not
up to date". jglick, I think you should update the specs on mozilla.org  as soon
as they are updated.

Otherwise you are misleading people like me.

Comment 5

17 years ago
Hakan, i'm sorry, there are so many specs its hard to keep all of them up to 
date all of the time, but i'll try and keep on top of it better.

The spec has now been updated (give it sometime to showup on moz):
http://www.mozilla.org/mailnews/specs/threepane/MailMenus.html

I posted this in 76247:
Standalone Window stuff (spec is outdated from when we couldn't navigate in the 
Standalone window yet).  Updating spec right now, but until then:

File Menu, Disable:
Open Message
Rename Folder (or Account)...

Edit Menu, Disable:
Undo 
Redo 
Cut
Paste
Edit Draft
Select --->
Folder Properties 

View Menu, Disable:
Message
Sort by --->
Messages --->
(Reporter)

Comment 6

17 years ago
Jennifer, thanks for updating...

Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.