Creates ontouchstart event but does not ever fire on desktop

RESOLVED DUPLICATE of bug 970346

Status

()

RESOLVED DUPLICATE of bug 970346
6 years ago
4 years ago

People

(Reporter: jef_wizkid, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121023042010

Steps to reproduce:

Checed for the availability of touch events on Firefox Aurora 18.0a2 by using the "'ontouchstart' in document.documentElement" method.


Actual results:

It said it was registered, so my, and the scripts written by many others presumed it was going to fire this event, since it was registrable. It however, to my saddening did not.


Expected results:

It should have fired ontouchstart on normal clicks, or like every other browser, and thus has my preference, do not register the event at all, if not on a touch enabled device.

Comment 1

6 years ago
Same problem on Firefox Nightly 20.0a1 (2012-12-11).

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20121211 Firefox/20.0
Build ID: 20121211030855
I think this is a duplicate of bug 970346.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 970346
You need to log in before you can comment on or make changes to this bug.