Gmail imap server returns "account exceeded command or bandwidth limits" due to exceeding 10 simultaneus imap connections, user gets blocked from gmail imap servers for 24 hours

RESOLVED DUPLICATE of bug 806760

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 806760
5 years ago
5 years ago

People

(Reporter: linus, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010234852

Steps to reproduce:

Upgraded to 16.0.1.

After a while i started getting "account exceeded command or bandwidth limits" errors and was unable to connect to gmail imap servers. I contacted google apps support and they've reset my account limits a few times, but it keeps happening every day still. The block stays active for 24h. They have a 10 connections limit.
http://support.google.com/mail/bin/answer.py?hl=en&answer=97150

They've also verified that it's not a bandwidth related issue.




Actual results:

I received this in an email from google apps support:

"Regarding your issues with IMAP lockouts, we've seen an increase of cases where customers are being locked out due to the latest update to Thunderbird (16.0.1). If you're using this client I'd recommend downgrading or switching to a different client to prevent this issue from occurring again. I've had the account reset now as a courtesy but won't be able to do so again. Because of this, I'd recommend making one of the above suggested changes to avoid the IMAP lockout going forward."



Expected results:

I shouldn't have been blocked from accessing my email. This behaviour did not exist with Thunderbird 15.

Comment 1

5 years ago
Can you try to set a limit in account settings -> account -> server settings ->advanced?
Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core
is this perhaps related to the redownlloading bug?

Comment 3

5 years ago
There appear to be multiple serious IMAP issues in the latest version.
The advice to downgrade is a sound one, I think.
(Reporter)

Comment 4

5 years ago
aceman, i've changed "Maximum number of server connections to cache" to 1 and still get the error. Anything else you want me to check/try?

wsmwk, What/where is the redownloading bug?

One link to a thread with other people having trouble with this:
https://productforums.google.com/forum/?fromgroups=#!topic/gmail/xP9BsXL-AP4

Comment 5

5 years ago
linus: bug 803843.
Did you update to 16.0.2 and still see the issue ?
(Reporter)

Comment 7

5 years ago
Updated to 16.0.2 two or so hours ago and it hasn't happened since. If it's not happening tomorrow, I could close this issue.

Comment 8

5 years ago
same with 16.0.2 TB version    on Lubuntu 12.10 32 bits

imap with gmail
i'm doing many delete in the imap account without archiving them 
(delete is delete !!!)
(stupid option from gmail needs you to move the deleted mails to your local trash if you don't want them in their permanent bloody archive system)
=> heavy traffic between thunderbird and gmail imap
most of this mails having join files from 5 to 15 Mo

yesterday all was freezed so i do small tests only

to night i will try
* lowering server "settings ->advanced" options
* modifiyng gmail config to archive deleted mails without downloading them to the local trash

Comment 9

5 years ago
some hints there 
https://support.google.com/a/bin/answer.py?hl=en&answer=1071518&topic=28609&ctx=topic

[Upload via IMAP 	500 MB] could be a strong limit

but this does not answer why it was ok in TB 15 and not in TB 16

Comment 10

5 years ago
TB 16 has a bug of downloading some messages repeatedly. That should be fixed in TB16.0.2.

So upgrade to it and way a day until the limit is reset. Then watch it again.

Comment 11

5 years ago
way = wait.
(Reporter)

Comment 12

5 years ago
I just got blocked again due to "account exceeded command or bandwidth limits". I've sent an email to the google apps support asking if it's due to number of connections as before, or due to bandwidth.

Updated

5 years ago
Depends on: 806760

Comment 13

5 years ago
Version: 16.0.2
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20121028 Thunderbird/16.0.2
Build-ID: 20121028144826

I observe the same error message when trying to download email from gmail via IMAP.

I just talked to the german help center of google (esupport@google.com) and they told me I had downloaded more than 2.5G of email data within 24 hours. They could break this down to thunderbird connections - and they told me this would be a known problem of Thunderbird 16.X.

Just like domi stated it, some hours before the lockout I started to delete a few hundreds of messages. This is all I can contribute to the problem, sorry.
Thanks for the reports, we're working on what we believe is the cause of this problem in bug 806760.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Depends on: 815730
(Reporter)

Comment 15

5 years ago
I've updated to Thunderbird 17 and used it for about a week. The problem hasn't appeard since. I guess this issue can be closed.

I dont know if i'm supposed to do it, or if someone else is supposed to do it. So I'll just leave it as is. :)

Comment 16

5 years ago
So is this a dupe of bug 806760?

But there is still a variant of this tracked in bug 815730.
Flags: needinfo?(irving)
Anyone who is still seeing problems with repeated downloading when offline storage is turned on, should go to bug 815730.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(irving)
Resolution: --- → DUPLICATE
Duplicate of bug: 806760
You need to log in before you can comment on or make changes to this bug.