Closed Bug 805837 Opened 7 years ago Closed 7 years ago

add Growl support back for Firefox 18 (Aurora)

Categories

(Toolkit :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox18 + fixed

People

(Reporter: jaas, Assigned: jaas)

References

Details

Attachments

(1 file)

Our XUL notification support, and native Notification Center support, should be getting much better in Firefox 19. I removed Growl in Firefox 18, leaving OS X users with only a basic Notification Center implementation for alerts. I think we should add Growl back to Firefox 18 so there is no gap between when we remove Growl and significantly improved alert support.
Will this also cover adding it back to comm-central (bug 792793), which was in response to your removal from toolkit?
(In reply to Patrick Cloke [:clokep] from comment #1)
> Will this also cover adding it back to comm-central (bug 792793), which was
> in response to your removal from toolkit?
Sorry, I meant the corresponding comm-<branch>, which is comm-aurora, apparently.
(In reply to Patrick Cloke [:clokep] from comment #1)
> Will this also cover adding it back to comm-central (bug 792793), which was
> in response to your removal from toolkit?

No, this bug will not cover anything related to comm-central.
Blocks: 806254
Attached patch fix v1.0Splinter Review
Can someone with Growl installed please test this patch? It was a pretty clean backout. I also disabled Notification Center support entirely, I think we should wait for the refinements coming in Firefox 19.
Attachment #676136 - Flags: review?(doug.turner)
Comment on attachment 676136 [details] [diff] [review]
fix v1.0

Review of attachment 676136 [details] [diff] [review]:
-----------------------------------------------------------------

this looks like it relands when was removed.  Is it easier to just hg backout your change?
Attachment #676136 - Flags: review?(doug.turner) → review+
(In reply to Doug Turner (:dougt) from comment #5)

The patch is an hg backout with a minor tweak to turn off Notification Center entirely.
Comment on attachment 676136 [details] [diff] [review]
fix v1.0

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 777409
User impact if declined: we'll have prematurely removed Growl support
Testing completed (on m-c, etc.): none
Risk to taking this patch (and alternatives if risky): not risky
String or UUID changes made by this patch: none
Attachment #676136 - Flags: approval-mozilla-aurora?
Make sure to check with Asa about your plan in https://bugzilla.mozilla.org/show_bug.cgi?id=777409#c43 before completely disabling this feature in future versions.
Attachment #676136 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
pushed to mozilla-aurora

http://hg.mozilla.org/releases/mozilla-aurora/rev/8bc339726865

Should have QA verify the fix for this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Hey Juan, Hey Marcia see comment #9 could you help Josh, thanks!
You need to log in before you can comment on or make changes to this bug.