All users were logged out of Bugzilla on October 13th, 2018

(un)Sychronisation of IMAP mail tree doesn't remove local copies

RESOLVED DUPLICATE of bug 1302193

Status

RESOLVED DUPLICATE of bug 1302193
6 years ago
a year ago

People

(Reporter: ajb2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Thunderbird currently by default caches (synchronises) Imap server folders to local disk.

Switching off caching (synchronisation), doesn't result in the cache being flushed.


Actual results:


Cached data in folders in Imapmail are not removed/zeroed when synchronisation is disabled.


Expected results:


Cached folders in Imapmail should be flushed when sychronisation is disabled.

They will resynchronise when caching is enabled again and in the meantime there may be changes on the server which render the cache invalid.

Updated

6 years ago
Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core
Summary: (un)Sychronisation of Imapmail tree → (un)Sychronisation of IMAP mail tree doesn't remove local copies

Comment 1

6 years ago
Also see SeaMonkey bug 190304 on this issue. Per discussion there, choosing *not* to synchronize one or more folders may be temporary, thus older messages would have to be re-synchronized if the synchronization is enabled again. Thus, the current behavior may be intentional.

I'd agree though that having some function to clear the synchronized folders on purpose would be useful, thus to allow the complete removal of previously synced local data if desired so, without the need to manually locate the profile folder and to remove the mailbox files there.
(Reporter)

Comment 2

6 years ago
I don't know about other users but one of the reasons I'd switch off synchronisation would specifically be to clear things out and resynchronise (I actually do this on my laptop periodically for various reasons)

Resynchronisation is (or should be) a background process in any case.

As far as I'm concerned (from an IMAP admin point of view), synchronised folders are cache, not canonical and invalid caches should be flushed asap as they cause more problems than the solve. This is from practical experience dealing with users who have "funnies" in their folders.

Comment 3

6 years ago
We use SeaMonkey with IMAP in our company and we don't want local message caching, as it stores private data on local disks.
As it stands, it is quite difficult to manage the system in such a way that it does not store messages with IMAP.
Sure it is possible to switch off synchronization using the GUI, but it should be possible using (locked) prefs as well.
This includes the issue of not removing cached messages in that case.

It also appears that little testing is done for the codepaths involved in using IMAP without caching.
duping forward
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1302193
You need to log in before you can comment on or make changes to this bug.