[Settings] Update icon for Feedback to reflect new artwork in App Icon

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: pla, Assigned: kaze)

Tracking

({polish})

unspecified
All
Other
polish

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: visual design)

Attachments

(1 attachment)

Comment hidden (empty)

Updated

6 years ago
Component: Gaia → Gaia::Settings
Currently the "improve firefox os" label in the settings list is a "?" icon, it should be the thumbs up icon.
Priority: -- → P3
(Reporter)

Comment 2

6 years ago
Hi Kaze,

Eric was updating the settings icons and couldn't find where this icon resides.  Can you enlighten us as to its location?
Flags: needinfo?(kaze)
(Assignee)

Comment 3

6 years ago
Hi Peter,

all icons have been concatenated into one sprite, see:
/apps/settings/style/images/icons_sprite.png
Flags: needinfo?(kaze)
(In reply to Fabien Cazenave [:kaze] from comment #3)
> Hi Peter,
> 
> all icons have been concatenated into one sprite, see:
> /apps/settings/style/images/icons_sprite.png

Hi Fabien,

Thanks!  But the problem is that I don't know where to add the feedback icon in the sprite.  Currently Feedback (Improve B2G OS) and Help use the same icon, so if replace it in the sprite the icon will change for both of them instead of just feedback.  Hope that makes sense!
(Assignee)

Updated

6 years ago
Assignee: pla → kaze
blocking-basecamp: --- → ?
Should be fixed in the UX branch
blocking-basecamp: ? → -
(Assignee)

Comment 6

6 years ago
Created attachment 694866 [details] [diff] [review]
patch proposal
Attachment #694866 - Flags: review?(etienne)
(Assignee)

Comment 7

6 years ago
Comment on attachment 694866 [details] [diff] [review]
patch proposal

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: no icon for the “Improve B2G OS” item
Testing completed: manual
Risk to taking this patch (and alternatives if risky): none
Attachment #694866 - Flags: approval-gaia-master?(21)
Attachment #694866 - Flags: review?(etienne) → review+
Attachment #694866 - Flags: approval-gaia-master?(21) → approval-gaia-master+
(Assignee)

Comment 8

6 years ago
https://github.com/mozilla-b2g/gaia/commit/4f9d8e2e397002ef7f14c31378c026ce5cf22370
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.