10/26 daily build is hosed (boots only to black screen)

VERIFIED FIXED

Status

defect
--
blocker
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: jhammink, Assigned: slee)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(firefox18 fixed, firefox19 fixed)

Details

Attachments

(2 attachments)

129.52 KB, text/plain
Details
115.78 KB, text/plain
Details
I installed unagi_2012-10-26.zip from https://releases.mozilla.com/b2g/2012-10-26/

from system.xml
gaia 62e1eb4d46ec824098717addf01d9c8fe26178ca
gonk e6403c71e9eca8cb943739d5a0a192deac60fc51
gecko a6fd67a9b7e5929020cb7368c66b6fbe4564dc86

And the build is hosed!  I am seeing only a black screen but am getting some adb activity.

Unagi_2012-10-26_eng.zip is also hosed.


OTA updates from 10/25 to 10/26 work ok; at least I have a UI there.
Major smoke test bustage on Unagi. Need help finding an assignee.
Severity: normal → blocker
blocking-basecamp: --- → ?
Flags: needinfo?(overholt)
It's already fixed by landing bug 797798
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
blocking-basecamp: ? → ---
Flags: needinfo?(overholt)
Oh in that case, lets dup on that bug then. I'm flagging qawanted on this bug to confirm this is fixed in the following daily smoke test build on unagi, though.
Keywords: qawanted
Resolution: INVALID → DUPLICATE
Duplicate of bug: 797798
blocking-basecamp: --- → ?
Keywords: qawantedverifyme
bug 797798 regressed and broke the 10/26 daily build.   Will re-verify the fix after a new build is spun tomorrow with the patch there.
Blocks: 797798
blocking-basecamp: ? → +
Keywords: verifymeregression
Resolution: DUPLICATE → FIXED
Assignee: nobody → slee
This looks good using the 2012-10-27 build - no more black screen using the latest nightly.
Status: RESOLVED → VERIFIED
I am getting this behavior as well. Device works but shows a black screen. I'm building for inari. I thought the problem might be an irq conflict or related to this bug: in bug https://bugzilla.mozilla.org/show_bug.cgi?id=821480
I'm compiling version commit 4aabed65e0147d7c44e64bce53b2f829a67bfcd1 Merge: 605ee4d c236ffa
I also see in dmesg and logcat many many errors stating: perform_lock_unlock_operation: GENLOCK_IOC_DREADLOCK failed (lockType0x1, err=Invalid argument fd=15)

According to Michael Vines [:m1] [:evilmachines] 2012-12-14 10:55:41 PST from linked bug above
"Genlock errors like this are typically very serious and imply something very broken about how EGL/GLES is being used.  This is a stability issue that needs to resolved to successfully commercialize the platform."
Posted file dmesg
This is a dmesg after the device boots.
Posted file logcat
This is a logcat after the device boots
blocking-basecamp: + → ---
You need to log in before you can comment on or make changes to this bug.