SOCKS: no window opens on startup if the socks port in the proxies preferences is set

VERIFIED WORKSFORME

Status

SeaMonkey
Preferences
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Niko Pavlicek, Assigned: neeti)

Tracking

({hang})

Trunk
mozilla0.9.2
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If I set the socks port in the preferences window for the proxies mozilla
doesn't open a window on startup.
I can only see an entry in the windows startbar with the seamonkey icon w/o a
title, if I delete the entry from the prefs.js moz starts correctly. There are
no problems for any other proxy prefs, I tried it step 4 step with all proxy
prefs and the only one which causes problems is the one for the socks port.

build id: 2001051220, win32 installer
There is no evidence of any problem reading or writing the raw preference, so 
the problem is in a client of the preference service. Changing Component to 
"Networking" as the closest fit. 
Assignee: dveditz → neeti
Component: Preferences: Backend → Networking
QA Contact: sairuh → tever

Comment 2

17 years ago
qa to me.

Two possible problems:

1- You SOCKS server supports only V4. 
I recoommend using AIM (because you have a version selector for SOCKS) to see if
V5 works.

2- SOCKS is also just broke in recent builds (bug 74546). 

Please try to isolate the version of the SOCKS server, so we can keep the two
problems separated.
QA Contact: tever → benc
(Reporter)

Comment 3

17 years ago
my proxy supports socks v4 AND v5, but my proxy isn't the problem - I have no
problems if I start mozilla, then enter the socks proxy settings and begin to
surf! But, mozilla crashes if I then close and relopen mozilla.

And:
it's definitely NOT bug 74546! I don't have problems with the connection as
described above - moz just crashes if there is ANY entry for the socks port.
(Reporter)

Comment 4

17 years ago
ok, new build (2001051620) - new problem:
with the new build it doesn't crash anymore, but it just shows an totally empty
grey window - empty title bar, no ui-parts

Comment 5

17 years ago
-> NEW.
+hang, nsbeta1, nscatfood.

You have a new problem. Thanks for providing the additional information.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang, nsbeta1, nsCatFood
Summary: no window opens on startup if the socks port in the proxies preferences is set → SOCKS: no window opens on startup if the socks port in the proxies preferences is set
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.2
(Assignee)

Comment 6

17 years ago
This worksforme in a build pulled on windows 2000 on 06/04
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
If this is WFM, why is it marked FIXED?

Niko, please try a more recent build and see if SOCKS works for you.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

17 years ago
I marked this as fixed instead of WFM, because a few days back I could reproduce 
the problem, but now it works fine.

Some checkin caused this to be fixed.

Comment 9

17 years ago
What checkin would do this? I have not heard of any checkins related to SOCKS.

Since there are not clear steps here, let me ask:

When you reproduced the problem, was it entry of just a PORT number and no
HOSTNAME in preferences?

(Assignee)

Comment 10

17 years ago
I do not remember whether I just typed in PORT number and no HOSTNAME in 
preferences, but I recollect that once I did this I had trouble opening the 
preference window again. I think this problem is related to preferences.
(Reporter)

Comment 11

17 years ago
ok, the steps to reproduce had been:

- set a SOCKS PROXY name/ip
- restart mozilla
- set a SOCKS PROXY PORT (1080)
- restart mozilla
 => no window opens
- delete the line
  "user_pref("network.proxy.socks_port", 1080);"
  from prefs.js
- start mozilla
 => mozilla opens

but with a current build (2001060720 - win32 installer) it worksforme, so
something fixed it. I think it wasn't a socks problem, but a problem with the
"prefs-reader" or at least something which depends on the prefs-file and not the
actual setting.
(Assignee)

Comment 12

17 years ago
marking wfm per reporter
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
-> prefs to see if they know what is going on...
Component: Networking → Preferences

Comment 14

16 years ago
VERIFIED, all plats:
I do not have this problem with Mozilla 0.9.8, using SOCKS V5.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.