Google Chat should accept e-mail addresses @googlemail.com

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Tobbi, Unassigned)

Tracking

({regression, steps-wanted})

Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird17-, thunderbird18-)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

7 years ago
I tried setting up my GChat accounts with Thunderbird a few weeks ago and it never succeeded. At first I thought that my password would be truncated by TB because it was too long, however, I now find that the issue is that GChat doesn't recognize the @googlemail.com suffix as being a Google Chat one. 

It works with 'name@gmail.com' and just 'name', but not with 'name@googlemail.com'.
Reporter

Comment 1

7 years ago
Posted patch patch (obsolete) — Splinter Review
Assignee: nobody → tobbi.bugs
Status: NEW → ASSIGNED
Reporter

Updated

7 years ago
Attachment #675833 - Attachment is obsolete: true
Reporter

Comment 2

7 years ago
Posted patch patch v2Splinter Review
Reporter

Updated

7 years ago
Attachment #675835 - Flags: review?(florian)
Is this a regression from bug 795959?
Or is this a recent change on Google's servers?

I'm not sure I understand the problem. I can see why the Gtalk servers would only accept @gmail.com if we use the full bind authentication, but if the domain name has been provided in the account name, we don't use it.
Tobias can you verify what version of Thunderbird this was tried with?

bug 795959 is in Thunderbird 17, I believe. (Tobias have you tried with Thunderbird 17? Currently in beta, I believe.)

(In reply to Tobias Markus (:Tobbi) from comment #0)
> I now find that the issue is that GChat
> doesn't recognize the @googlemail.com suffix as being a Google Chat one. 
I'm a little confused by this, when you say "GChat doesn't recognize" do you mean "Thunderbird connecting to Google Talk" or "the Google Talk service"? Is there some documentation somewhere that says to use gmail vs. googlemail, etc. or is it just an issue with Thunderbird?
Reporter

Comment 5

7 years ago
(In reply to Patrick Cloke [:clokep] from comment #4)
> Tobias can you verify what version of Thunderbird this was tried with?

I was trying this with the latest Thunderbird Daily version.

> bug 795959 is in Thunderbird 17, I believe. (Tobias have you tried with
> Thunderbird 17? Currently in beta, I believe.)

No, I haven't tried that yet.

> (In reply to Tobias Markus (:Tobbi) from comment #0)
> > I now find that the issue is that GChat
> > doesn't recognize the @googlemail.com suffix as being a Google Chat one. 
> I'm a little confused by this, when you say "GChat doesn't recognize" do you
> mean "Thunderbird connecting to Google Talk" or "the Google Talk service"?
> Is there some documentation somewhere that says to use gmail vs. googlemail,
> etc. or is it just an issue with Thunderbird?

About that, I'm not certain. All I can say is that it doesn't work when I put my prefix@googlemail.com. If you want me to find certain debug information, feel free.
Reporter

Comment 6

7 years ago
Completely unrelated to this, but:
http://mxr.mozilla.org/comm-central/source/chat/protocols/gtalk/gtalk.js#34

Shouldn't 'Stanza' be renamed to 'aStanza' as that's the argument we pass to the function?
I can confirm this bug with Thunderbird 18.0a2 (Earlybird).

I have a googlemail.com account and it works fine with Instantbird (1.3a1pre) but throws this error[1] with Thunderbird:

[1] "Not authorized (Did you enter the wrong password?)"
(In reply to Tobias Markus (:Tobbi) from comment #6)
> Completely unrelated to this, but:
> http://mxr.mozilla.org/comm-central/source/chat/protocols/gtalk/gtalk.js#34
> 
> Shouldn't 'Stanza' be renamed to 'aStanza' as that's the argument we pass to
> the function?

No, it's the Stanza object exported from xmpp-xml.jsm
I cannot reproduce this any longer with TB 15, 16, 17, 18.0a2 (Earlybird) and 19.0a1 (latest Daily). Maybe this was something on google’s site?
I also suspect it was a server issue, so resolving as WORKSFORME per comment 9.

Tobias, if you can still reproduce, feel free to reopen.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Attachment #675835 - Flags: review?(florian)
Reporter

Comment 11

7 years ago
(In reply to Florian Quèze [:florian] [:flo] from comment #10)
> I also suspect it was a server issue, so resolving as WORKSFORME per comment
> 9.
> 
> Tobias, if you can still reproduce, feel free to reopen.

Sorry, but I can still reproduce the issue with tobbi.sumo@googlemail.com for example.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Tobias Markus (:Tobbi) [hiatus beginning January 2013] from comment #11)
> (In reply to Florian Quèze [:florian] [:flo] from comment #10)

> Sorry, but I can still reproduce the issue with tobbi.sumo@googlemail.com
> for example.

FeuerFliege can successfully connect with his @googlemail.com email, so I'm afraid there's something missing in the steps to reproduce :-/.
(In reply to Tobias Markus (:Tobbi) [hiatus beginning January 2013] from comment #11)
> 
> Sorry, but I can still reproduce the issue with tobbi.sumo@googlemail.com
> for example.

Did you try a fresh profile?
Not tracking for now as there's no steps to reproduce.
Reporter

Updated

5 years ago
Assignee: tobbi.bugs → nobody
Status: REOPENED → NEW
According to https://support.google.com/talk/answer/24073 you should enter the part of your email that's after the @, i.e. googlemail.com, although it says if it unlinked to any Google Mail product to use gmail.com (whatever that means).

Bug 795959 also implemented https://developers.google.com/talk/jep_extensions/jid_domain_change which allows us to just enter your log in name (e.g. clokep for me) and things should "just work".

Since no one else has been able to reproduce this (and it seems the reporter is no longer involved in Mozilla), I'm going to close this as WORKSFORME. Please reopen/file a new bug with Steps to Reproduce and an XMPP debug log if this is still occurring for someone.
Status: NEW → RESOLVED
Closed: 7 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.