TB 16.0 status message - chinese translation error accures while moving mails from one folder to another

RESOLVED FIXED

Status

Mozilla Localizations
zh-CN / Chinese (Simplified)
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: iridiumcao, Assigned: Shaohua Wen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 675834 [details]
detais of the bug

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

Delete a bound of mails (>10000+)


Actual results:

The status message in Chinese is wrong: the number of total messages and the number of messages deleted are wrote in wrong positions.

BTW, it's correct in English, pls refs to the attached pic.


Expected results:

Display right status message in Chinese.

Updated

5 years ago
Assignee: nobody → shaohua.wen
Component: Untriaged → zh-CN / Chinese (Simplified)
Product: Thunderbird → Mozilla Localizations
QA Contact: shaohua.wen
Summary: chinese translation error accures while moving mails from one folder to another → TB 16.0 status message - chinese translation error accures while moving mails from one folder to another
Version: 16 → unspecified

Updated

5 years ago
(Assignee)

Comment 1

5 years ago
Fixed in Aurora.

hg log  -l 1
修改集:      476:6d86e7031d12
标签:        tip
用户:        Shaohua Wen <shaohua.wen@gmail.com>
日期:        Sun Oct 28 12:02:29 2012 +0800
文件:        mail/chrome/messenger/localMsgs.properties suite/chrome/mailnews/localMsgs.properties
描述:
Bug 806084 - TB 16.0 status message - chinese translation error accures while moving mails from one folder to another
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

5 years ago
hi, please see the attached pic, the message in Chinese is wrong.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

5 years ago
Looking at Shaohua Wen's patch, the text remains unchanged but the order of the numbers was switched to match the English version (though I would have expected "%S" rather than "$S" in the property string, but if it works, that should be fine). The change is effective in the current "Earlybird" builds, which you can get from http://www.mozilla.org/en-US/thunderbird/channel/ (follow the link underneath the left button to get to the localized versions; you can use either the installer or just unpack thunderbird-18.0a2.zh-CN.win32.zip to some folder).

Please read http://kb.mozillazine.org/Testing_pre-release_versions *before* using such a test version. If you want to test the fix, don't use a production ("real") profile for testing, and make sure either way to have a backup of your current profile, thus you can go back to the current release version without problems.
(Assignee)

Comment 4

5 years ago
Yes, you are right, I'll correct it.
(Assignee)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.