Services undefined (but used) in connection.js

RESOLVED FIXED in Thunderbird 19.0

Status

Thunderbird
Preferences
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Magnus Melin, Assigned: Magnus Melin)

Tracking

({regression})

Trunk
Thunderbird 19.0
regression

Thunderbird Tracking Flags

(thunderbird18 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 675874 [details] [diff] [review]
proposed fix

Open Network & Disk Space | Connection Settings

Error: Services is not defined
Source File: chrome://messenger/content/preferences/connection.js
Line: 82

From bug 763106.
Attachment #675874 - Flags: review?(acelists)

Comment 1

5 years ago
Comment on attachment 675874 [details] [diff] [review]
proposed fix

Thanks, good catch, patch looks good.
Should be nominated for Aurora?
Attachment #675874 - Flags: review?(mconley)
Attachment #675874 - Flags: review?(acelists)
Attachment #675874 - Flags: feedback+

Updated

5 years ago
Attachment #675874 - Flags: review?(mconley) → review+

Updated

5 years ago
Keywords: checkin-needed

Comment 2

5 years ago
Comment on attachment 675874 [details] [diff] [review]
proposed fix

[Approval Request Comment]
Regression caused by (bug #): bug 763106
User impact if declined: Preferences->Connection settings not working
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #675874 - Flags: approval-comm-aurora?
https://hg.mozilla.org/comm-central/rev/a424b55ad2d4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 19.0
Attachment #675874 - Flags: approval-comm-aurora? → approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/71139f1af016
status-thunderbird18: --- → fixed
You need to log in before you can comment on or make changes to this bug.