Searching words in PDF Viewer with rotated view broken

RESOLVED DUPLICATE of bug 803468

Status

()

Firefox
PDF Viewer
P2
normal
RESOLVED DUPLICATE of bug 803468
5 years ago
5 years ago

People

(Reporter: Jonah Ho (FireChemist), Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20130118])

(Reporter)

Description

5 years ago
Description:  Finding words using PDF Viewer in Firefox 18 when the PDF is rotated clockwise causes the searched word to appear without rotation and is flipped.

Build ID: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0
OS: Windows 7 x64

Steps to reproduce:
1. Open http://developer.amd.com/assets/43009_sb7xx_rrg_pub_1.00.pdf in Aurora
2. Change to page 152 and maintain zoom level as Automatic Zoom without navigational panel visible.
3. Rotate page clockwise once.
4. Press ctrl-f to search for "Field Name" without the quotation marks

Actual results:
The word is found and highlighted but is not rotated.  In addition, the highlighted word is flipped.

Expected results:
The found word should be highlighted with clockwise rotation because the page was rotated clockwise as well.  Also, the highlighted word should not be flipped.
(Reporter)

Updated

5 years ago
Whiteboard: [testday-20121102]
See also https://github.com/mozilla/pdf.js/issues/2095
Priority: -- → P2
Whiteboard: [testday-20121102] → [testday-20121102][pdfjs-c-ux][pdf-d-text-selection]
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 803468
Whiteboard: [testday-20121102][pdfjs-c-ux][pdf-d-text-selection]
Whiteboard: [testday-20130118]
You need to log in before you can comment on or make changes to this bug.