Downloading Nightly-oak stuck on "connecting to update server"

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: oeai, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 675936 [details]
Снимок экрана от 2012-10-28 15:28:32.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121026040203

Steps to reproduce:

Software update just appeared to upograde to ver 19.0a2
Downloading Nightly 
and it still connecting to update server.


Actual results:

still connecting to update server.


Expected results:

it should start the download

i got x64 earlybird, not sure if this is the issue, much more like it is because i've instaleld calendar, because when i was hitting the button help -> update it is redirecting me to the calendar ftp builds.
(Reporter)

Comment 1

6 years ago
Created attachment 675938 [details]
this is the page where i was redirected to
(Reporter)

Comment 2

6 years ago
Created attachment 675945 [details]
ooh it is the nightly update not the thunderbird one
(Reporter)

Comment 3

6 years ago
as about the earlybird it is not the bug it was a check latest lightning button,
there's no incremental update button in firefox and early bird at all, but i actually suppose that not the whole system is updating, this should be an *.xpi that can change some parts of the code if it is concerning triggers or new string or db changes and this xpi can include information of which files were changed during latest update and download them only if those cannot be changed through incremental string update inside the program itself.
(Reporter)

Updated

6 years ago
Component: Migration → Migration
Product: Thunderbird → Firefox
Version: 18 → 19 Branch
Component: Migration → Application Update
Product: Firefox → Toolkit
Summary: Software Update - Downloading Nightly - not working → Downloading Nightly-oak stuck on "connecting to update server"
(Reporter)

Comment 4

6 years ago
Created attachment 676547 [details]
the earlybird is using the same bug

Downloading Earlybird is failed too
(Reporter)

Comment 5

6 years ago
i resolved the bug - it is because i was trying to update from non-root account while the firefox directory itself is in /usr/share and needs root privileges, so for linux users
i see two ways - the one is to check the installation and move the folder into private $home folder so the updated version would be started from that place
or check the root and ask user to restart from root to update or provide some shell based gksu like authentication
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.