Closed Bug 806235 Opened 9 years ago Closed 5 years ago

Paste as Quotation Fails Even in Safe Mode

Categories

(Thunderbird :: Message Compose Window, defect)

16 Branch
x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 795418

People

(Reporter: scott.inrig, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Select a message in the Inbox and copy some text from it.
Start composing a new message (e.g. by ^N)
At the start of the message body area, type any character followed by a newline.
Right-click and select "Paste as Quotation".


Actual results:

Nothing.


Expected results:

The text copied from the Inbox message should have appeared in the body text.
Dear Thunderbird Developers,

Has there been any progress on this bug? I am using the latest Thunderbird (17.0.8) on Mac OS X 10.6.8. The "Paste as Quotation" feature is quite broken. After any text is selected (from a message or outside of Thunderbird), if the user attempts to do "paste as quotation" of the selection, into a message composition window, nothing happens; nothing at all is not pasted into the message. "Paste" alone works, so the text is indeed in the copy buffer, but Thunderbird won't paste it as quotation.

This, of course, is a useful feature that should be fixed. The obvious workaround, pasting a selection and manually attempting to make it look like quoted text, is not a very viable solution.

Thanks.
This works for me on 17.0.8 for both plain text and HTML mail (on Windows 7).
(In reply to eric raeburn from comment #1)
> Dear Thunderbird Developers,
> 
> Has there been any progress on this bug? I am using the latest Thunderbird
> (17.0.8) on Mac OS X 10.6.8. The "Paste as Quotation" feature is quite
> broken. After any text is selected (from a message or outside of
> Thunderbird), if the user attempts to do "paste as quotation" of the
> selection, into a message composition window, nothing happens; nothing at
> all is not pasted into the message. "Paste" alone works, so the text is
> indeed in the copy buffer, but Thunderbird won't paste it as quotation.
> 
> This, of course, is a useful feature that should be fixed. The obvious
> workaround, pasting a selection and manually attempting to make it look like
> quoted text, is not a very viable solution.
> 
> Thanks.

I confirm your behavior.

Mac OS X 10.8.4, Thunderbird 17.0.8.

THIS MAKES ME MAD, I regularly need this feature (to repair quotes since people don't know how to properly quote and to copy stuff from the shell)...
Same problem for me with Thunderbird 17.0.8 on Windows 7 (64 bits)
Yep, also broken for me with Thunderbird 24.0.1 on Windows 7 (32 bits)
Paste as Quotation fails for me in TB 31.2.0 on Fedora 20, whether in safe mode or regular.  This needs to be fixed ASAP.
Also on Debian 8.
(In reply to Kent West from comment #7)
> Also on Debian 8.

I should mention that this is Debian's rebranded Thunderbird, Icedove, 31.3.0.
Dup of Bug ID 795418?
Sure seems so. Could somebody mark it as a duplicate of that bug?
Version: 45.6.0
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.6.0
Application Build ID: 20161222195647

Issue still exists.

Issue still a duplicate of bug 795418.
There are 2 partial workarounds described.
Thanks Lars & Co for pointing out the duplicate.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795418
You need to log in before you can comment on or make changes to this bug.