Last Comment Bug 806236 - Update info.plist (register svg files and playable media types, clean up icons)
: Update info.plist (register svg files and playable media types, clean up icons)
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: OS Integration (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: seamonkey2.17
Assigned To: Stefan [:stefanh]
:
:
Mentors:
: 441061 726488 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-28 13:52 PDT by Stefan [:stefanh]
Modified: 2013-09-27 16:29 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
WIP (218.47 KB, patch)
2012-10-28 13:56 PDT, Stefan [:stefanh]
no flags Details | Diff | Splinter Review
Better icon (219.45 KB, patch)
2012-10-28 14:17 PDT, Stefan [:stefanh]
no flags Details | Diff | Splinter Review
New version (221.16 KB, patch)
2012-11-12 03:05 PST, Stefan [:stefanh]
no flags Details | Diff | Splinter Review
Not really any whitespace changes (218.73 KB, patch)
2012-11-15 13:11 PST, Stefan [:stefanh]
mnyromyr: review+
Details | Diff | Splinter Review

Description Stefan [:stefanh] 2012-10-28 13:52:32 PDT
In bug 803781, Philip made me aware of that we miss a few updates to our info.plist file:
Bug 650451 - Associate the application with playable media types on Mac.
Bug 474401 - Firefox on Mac does not register itself as being capable of
opening SVG files.

I also think we should use one icon file for all file types - it's much easy to maintain and no-one will ever update the old Mozilla Suite styled .icns files. Lets go for a standard icon with just the seamonkey logo on it.
Comment 1 Stefan [:stefanh] 2012-10-28 13:56:08 PDT
Created attachment 675983 [details] [diff] [review]
WIP

What's left here is to check the .icns file and make sure it's OK.
Comment 2 Stefan [:stefanh] 2012-10-28 14:17:11 PDT
Created attachment 675988 [details] [diff] [review]
Better icon

This one should be better...
Comment 3 Philip Chee 2012-10-29 11:54:01 PDT
Could you split this into two patches, the first one being just whitespace changes? This makes blame easier to look at.
Comment 4 Stefan [:stefanh] 2012-11-12 03:05:05 PST
Created attachment 680573 [details] [diff] [review]
New version

I forgot to change the makefile... But the new .icns file doesn't seem to work - I need to investigate.
Comment 5 Stefan [:stefanh] 2012-11-15 13:11:00 PST
Created attachment 682157 [details] [diff] [review]
Not really any whitespace changes

I reverted my excessive whitespace edits (just removed the empty lines between the <dict>:s) and discovered one missing addition of document.icns. The new icon file seems to work now for me - you might have to run make in the installer dir and then move the package to some other location (not sure, but iirc it's the actuall install, e.g dragging & dropping the .app, that makes the OS aware of the icns files).
Comment 6 Stefan [:stefanh] 2012-11-15 13:15:12 PST
Ah, yeah - I removed a bunch of CFBundleTypeName's since I really didn't see any point having them there (Firefox doesn't have them and I like to remove old stuff that we don't really use - some of those extensions are also unknown to me)
Comment 7 Karsten Düsterloh 2012-11-23 13:47:21 PST
Comment on attachment 682157 [details] [diff] [review]
Not really any whitespace changes

>+	cp $(srcdir)/icons/mac/document.icns          $(DIST)/branding/icons/document.icns
> 	cp $(srcdir)/icons/mac/seamonkey.icns         $(DIST)/branding/icons/seamonkey.icns

Nice to see big icons in document.icns, wouldn't it be useful to have such in seamonkey.icns as well?
Comment 8 Stefan [:stefanh] 2012-11-24 06:09:04 PST
(In reply to Karsten Düsterloh from comment #7)
.
.
.
> Nice to see big icons in document.icns, wouldn't it be useful to have such
> in seamonkey.icns as well?

Yeah, it would.
Comment 9 Stefan [:stefanh] 2012-11-24 06:09:29 PST
http://hg.mozilla.org/comm-central/rev/389b69f005ff
Comment 10 Stefan [:stefanh] 2013-09-22 10:34:42 PDT
*** Bug 441061 has been marked as a duplicate of this bug. ***
Comment 11 Stefan [:stefanh] 2013-09-27 16:29:08 PDT
*** Bug 726488 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.