Can't move windows when persona activated

RESOLVED FIXED in mozilla19

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: nthomas, Assigned: jaas)

Tracking

Trunk
mozilla19
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Workaround: switch back to default theme)

I can confirm this.

Furthermore I've found out that the window can be dragged via the tabbar (while using the light-theme a.k.a Personas)
Any idea what is going on here, Markus?
Taking this for now, but I'm not sure I can fix this before a backout would make more sense.
Assignee: nobody → joshmoz
In Persona mode, there is no movable box installed in the title bar, the title bar is only filled with the window's padding-top (from mxr.mozilla.org/mozilla-central/source/toolkit/content/xul.css#29 ). Prior to bug 647216 that didn't make a difference because the window was always draggable in the title bar, but now we actively disable dragging.

I'm not sure yet what the simplest way to fix this is. We should probably back out bug 647216 until we have a plan.
Dão, the xul.css padding-top rule probably needs to go. Should we move the padding-top to some draggable toolbar (like the tabs toolbar in tabs-on-top mode) instead, or should we look into making the CAN_DRAW_IN_TITLEBAR stuff apply on Mac, too? I don't think we want a Firefox button on Mac, so the XUL will need to look differently on Mac anyway so it might not make sense to reuse that code.
Eventually we need CAN_DRAW_IN_TITLEBAR on Mac for tabs in the title bar. The Firefox button is going away, but for now any code expecting it should depend on MENUBAR_CAN_AUTOHIDE.
Blocks: 625989
Duplicate of this bug: 806521
Backout isn't clean, I'll have to update it to current trunk.
I have a backout prepared, I'll land it soon.

Who can resolve the issue here? Markus or Dão?
I backed out the patch causing this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.