Status

www.mozilla.org
Bedrock
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rik, Assigned: pmac)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=dev c=email p=)

(Reporter)

Description

5 years ago
We're receiving a lot of timeouts from the ExactTarget API. From our conversation with ExactTarget, we should use the asynchronous API cause it should respond under a second.

Or we could switch our calls to Celery. But that depends on bug 730388.
(Reporter)

Comment 1

5 years ago
I think we should take this in our next sprint.
Malexis: can you put it in the ready backlog?

In case we choose to go with the async API, here are the docs http://docs.code.exacttarget.com/020_Web_Service_Guide/Technical_Articles/Asynchronous_Processing
Priority: -- → P1

Updated

5 years ago
Whiteboard: u=dev c=email p=

Updated

5 years ago
Assignee: nobody → pmac

Updated

5 years ago
Duplicate of this bug: 816529
Depends on: 730388
We've decided to go with Celery. Working with IT on it now.

Comment 4

5 years ago
pmac: Should have sancus look into this or is your domain knowledge in this area beneficial to have you work on this further when you have an opportunity?
I'll keep this one. I've done a good bit and have a PR ready for the code part, though the merge might be hairy since much has changed in the interim. After that it's just a matter of coordinating w/ IT.
Blocks: 821255

Comment 6

5 years ago
Commits pushed to master at https://github.com/mozilla/basket

https://github.com/mozilla/basket/commit/945584373353b1f851d930dd208f5b018d9d6e73
Bug 806327: Enable async ET operations.

https://github.com/mozilla/basket/commit/8f13d3970175c8a23239f96c93fae0996f0098f7
Merge pull request #21 from pmclanahan/bug-806327-async-subscribe

Bug 806327: Enable async ET operations.
Basket is now async using celery in production. These should go away entirely now. We'll reopen if not.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.