Closed Bug 806382 Opened 7 years ago Closed 7 years ago

ostream header is not wrapped, hidden symbols with gcc 4.1.2 and x86_64

Categories

(Core :: XPCOM, defect)

17 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 893508

People

(Reporter: jhorak, Unassigned)

Details

There's missing stl wrapper for ostream in case gcc 4.1.2 is used for compilation.

It's included in:
http://mxr.mozilla.org/mozilla-central/source/gfx/angle/src/compiler/preprocessor/new/Token.h

To fix this problem append ostream to stl-headers: 
http://mxr.mozilla.org/comm-central/source/mozilla/config/stl-headers
I'm surprised you can build at all with gcc 4.1.2.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893508
You need to log in before you can comment on or make changes to this bug.