Closed Bug 806414 Opened 7 years ago Closed 7 years ago

Do not automatically use HTTPS if it worked in the past

Categories

(Firefox :: Address Bar, defect)

16 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 769994

People

(Reporter: gtdev, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0 Iceweasel/16.0.1
Build ID: 20121011223555

Steps to reproduce:

An (internal) site, say, http://foo-bar/munin/ works. For a short time; https://foo-bar/munin/ works as well, but does not provide the appropriate service but a generic redirect.


Actual results:

After accessing the HTTPS site once, typing the HTTP URI in the location bar makes Firefox automatically attempt a connection to the HTTPS site, which does not provide the correct service.


Expected results:

The browser should have opened the HTTP site, as indicated on the location bar.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
Component: Untriaged → Location Bar
You need to log in before you can comment on or make changes to this bug.