Youtube html5 playback busted on nightly

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: johnath, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I noticed today that, when opted in to youtube's html5 trial[1], this video isn't playing:

http://www.youtube.com/watch?v=66-4uMQqerA

I see the controls flicker in for a second, but then just a black square without controls, video, or audio.

Found it while trying to reproduce bug 805331 which is about socialAPI interfering with flash playback, but this happens whether or not the social sidebar is active, so ehsan and I assume it's a separate bug.



[1] http://www.youtube.com/html5
I think this video simply doesn't have a WebM encoding on YouTube.

If I turn on media PR logging, it looks like that particular page is using HTMLMediaElement.canPlayType() to check if it can play H.264 media types, but not WebM, i.e. it looks like YouTube aren't even considering playing a WebM encoded version. The video doesn't play in Chromium on Linux - which doesn't ship with H.264 support enabled.

If I enable the GStreamer backend on Linux we play an H.264 version of the video plays, but the video is scaled to the incorrect size for some reason.

Another problem I noticed, is that Chromium or Firefox with the GStreamer backend built but disabled display a "The video is currently unavailable" message when they don't support that encoded formats, but Nightly Firefox does not.

Comment 2

6 years ago
Should we contact Google about this?
Yes. It's a breakage in their code which affects our users.

Comment 4

6 years ago
OK, I can write the email.  Who wants to be on the CC list?
http://www.youtube.com/watch?v=66-4uMQqerA is playing for me in today's Nightly on Linux now. Does it work for anyone else?
(In reply to Ehsan Akhgari [:ehsan] from comment #4)

> OK, I can write the email.  Who wants to be on the CC list?

I'm happy to be on the CC.

(In reply to Chris Pearce (:cpearce) from comment #5)
> http://www.youtube.com/watch?v=66-4uMQqerA is playing for me in today's
> Nightly on Linux now. Does it work for anyone else?

Yes, it's working for me now too, although there's a flash of a mis-aligned play button during the detection phase. There's often a delay between a video being posted and it being available in WebM. The issue is (likely) with failure handling in that transient condition, not that any particular video fails consistently.

Comment 7

6 years ago
Hmm, I wonder what should we write in the email now that the original issue is fixed?  :/
(In reply to Ehsan Akhgari [:ehsan] from comment #4)
> OK, I can write the email.  Who wants to be on the CC list?

I would like to be.

Comment 9

6 years ago
(In reply to comment #8)
> (In reply to Ehsan Akhgari [:ehsan] from comment #4)
> > OK, I can write the email.  Who wants to be on the CC list?
> 
> I would like to be.

In case I was not clear, I don't know what to write in that email.  :-)
(Reporter)

Comment 10

6 years ago
My sense is that a bug is a bug and it seems like they caught it. I can find a youtube contact and poke them about it, too, but I think that without a live issue to point to, they'd have trouble understanding what we were asking for (wouldn't we, if someone emailed us about an already-fixed bug?)

In any event, I'm gonna close this now that it's some combination of INVA (we don't play h264) and WFM.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.