Closed Bug 806531 Opened 7 years ago Closed 7 years ago

Incorrect WPA-EAP username/password does not trigger incorrect password prompt, retries with bad password forever

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-basecamp:-)

RESOLVED FIXED
blocking-basecamp -

People

(Reporter: bent.mozilla, Assigned: vchang)

Details

(Whiteboard: testrun 2, testrun 4, testrun 5.1)

Attachments

(1 file)

On Mozilla-G here in SF, entering an incorrect WPA-EAP username/password does not trigger the incorrect password prompt and seems to retry with the bad password forever.
This seems duplicate to Bug 804459.
Attached patch Patch v1.0Splinter Review
check CTRL-EVENT-EAP-FAILURE event and disable the wpa-eap network after retry three times.
Assignee: nobody → vchang
Attachment #692215 - Flags: review?(mrbkap)
blocking-basecamp: --- → ?
We're not doing WPA-EAP for v1 so this isn't a blocker.
blocking-basecamp: ? → -
Attachment #692215 - Flags: review?(mrbkap) → review+
https://hg.mozilla.org/mozilla-central/rev/87ec624190f2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
UCID: owd-13771
https://moztrap.mozilla.org/results/case/63630/
Whiteboard: testrun 2
The issue is happening in FTE when connecting to a wifi with a bad password on build:
Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9
Whiteboard: testrun 2 → testrun 2, testrun 4
Whiteboard: testrun 2, testrun 4 → testrun 2, testrun 4, testrun 5.1
You need to log in before you can comment on or make changes to this bug.