Update double-conversion and document the version we are at

RESOLVED FIXED in mozilla19

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: espindola, Assigned: espindola)

Tracking

unspecified
mozilla19
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
Created attachment 676311 [details] [diff] [review]
there was an "hg rm" missing in the last patch.
Attachment #676296 - Attachment is obsolete: true
Attachment #676296 - Flags: review?(jwalden+bmo)
Attachment #676311 - Flags: review?(jwalden+bmo)
Comment on attachment 676311 [details] [diff] [review]
there was an "hg rm" missing in the last patch.

Review of attachment 676311 [details] [diff] [review]:
-----------------------------------------------------------------

::: mfbt/double-conversion/update.sh
@@ +4,5 @@
>  # double-conversion source that we need.
>  
> +# This was last updated with git rev e5b34421b763f7bf7e4f9081403db417d5a55a36.
> +
> +set -e

Since we're already touching this...

We might consider putting all the third-party code in mfbt/double-conversion/src, then having update.sh and all the patches in mfbt/double-conversion.  Then update.sh could rm -rf src, then run the git clone/pull/whatever command that included the gitrev directly, then apply our patches.

I'm not going to let perfect be the enemy of good, but if you're feeling especially motivated, this seems like it'd be a nice thing to do, to avoid mixing our stuff directly amidst theirs.
Attachment #676311 - Flags: review?(jwalden+bmo) → review+
Backed out along with several others in order to get inbound green again, after a busted landing meant we lost test coverage for 7 pushes, and now have multiple failures:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=a145ded68994

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/553fb59b9ca0
https://hg.mozilla.org/mozilla-central/rev/1c6b13fd3b6a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Duplicate of this bug: 752059
You need to log in before you can comment on or make changes to this bug.