Closed Bug 806561 Opened 10 years ago Closed 10 years ago

Add checksum (SHA1) of modules that has no version number/debug info and are not well-known

Categories

(Socorro :: General, task)

x86_64
Windows 7
task
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 634726

People

(Reporter: mayhemer, Unassigned)

Details

Often I see modules with strange names or apparent or potential malware in crashreports.  There are often modules with just a random name since google doesn't find anything about them.  It might be useful to have a hash for these suspicious modules to check it on e.g. virustotal.com that accepts checksums to view existing analyzes records.
Ted, we don't even send something like this from the client, right?
No, we'd have to add this. I have some prototype code that adds MD5 hashes to minidumps, but I haven't integrated it yet.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 634726
You need to log in before you can comment on or make changes to this bug.