Get rid of sync "SELECT 1 FROM moz_historyvisits"

RESOLVED DUPLICATE of bug 834541

Status

()

RESOLVED DUPLICATE of bug 834541
6 years ago
2 years ago

People

(Reporter: taras.mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Snappy:P2])

(Reporter)

Description

6 years ago
It's used at http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/nsNavHistory.cpp#1132 and was caused by a win7 jumplist usecase.

quoting mak below:
We could probably skip the check in buildFrecent and BuildRecent, or just do the rebuild regardless (so we avoid contention).
The problem is shutdown, there we need to check if history has been cleared and if so update the lists, or we'd leak private data. We may always update the lists here as well but that means 2 additional async queries on shutdown even if that may not be needed (that is the most common case).
Or we could just provide in mozIAsyncHistory an async alternative to hasHistoryEntries.
I think it's worth to file a bug and work on this.
this has been partially mitigated by adding share caching of the hasHistoryEntries value, so that now it gets recalculated only when we were unable to read it yet.
It's still a valid though, since even happening once is bad for contention possibility.
Depends on: 834541
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 834541
You need to log in before you can comment on or make changes to this bug.