Upon wake from sleep, must manually reconnect wifi

RESOLVED DUPLICATE of bug 811833

Status

RESOLVED DUPLICATE of bug 811833
6 years ago
6 years ago

People

(Reporter: lmandel, Assigned: chucklee)

Tracking

({b2g-testdriver, unagi})

unspecified
ARM
Android
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

When my unagi phone resumes from sleep the wifi doesn't automatically reconnect. I have to manually go into settings and tap on the wifi network that I was previously associated with in order to reconnect. This is consistently reproducible on my phone.
Tim,

If my recall is right, this issue should have been considered in your previous design? Do we have bugs here?
Yeah, I am pretty sure wifi can be turned back on correctly (and rescans automatically) ... I cannot reproduce this issue on Otoro.

(In reply to Gene Lian [:gene] from comment #1)
> Tim,
> 
> If my recall is right, this issue should have been considered in your
> previous design? Do we have bugs here?

I won't say my code is free of bugs though :-/

qawanted added
Keywords: qawanted

Comment 3

6 years ago
qa can't reproduce this in mozilla wifi these days.   if someone else reproduces this, can you attach a logcat?
Lawrence, can you provide a logcat?
blocking-basecamp: ? → +
Flags: needinfo?(lmandel)

Comment 5

6 years ago
Pete Scanlon is also seeing this problem.
Created attachment 677042 [details]
Screenshot of connecting to null

I'll see about getting a logcat of the issue. In the meantime, here's a screenshot of the settings app. Note that wifi shows as "connecting to null..."

Please also keep in mind that I'm on a test drivers phone that is on a build from 20121024.
Flags: needinfo?(lmandel)
This bug is alleged to have been fixed since the last stable update.  We should be able to push out a new stable update today, or at worst tomorrow.  It's not worth spending a lot of time on this bug until we re-test with latest stable.

(I see this too on my dogfood phone.)
I can no longer reproduce this with the 20121031 stable build.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 9

6 years ago
I have just reproduced this issue with the 12/3 nightly.  Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

6 years ago
Keywords: qawanted
Chuck, can you investigate?  If not, perhaps Vincent or Blake can take it?
Assignee: nobody → chulee
Can we get a priority and target milestone for this>
The symptoms described here make this sound like the configured network(s) are disabled in the settings. I wonder if the code that we run on startup here: <http://hg.mozilla.org/releases/mozilla-beta/file/a56a7d60657b/dom/wifi/WifiWorker.js#l1731> isn't working for some people (in addition, I was seeing crashes on wpa_supplicant startup that might be related to the network enabling code).
How is this not a dup of bug 811833? Revert my change if disagree.

According to Blake at bug 811833 comment 25, phones accepted by bad wpa_supplicant.conf would need to be re-flashed with Gecko containing bug 811833.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811833
I can't reproduce this bug on both otoro and unagi, with nightly 2012_12-05_eng.

Test Cases:
1. With settings app opened, in wifi settings
   (1) Unplug USB
   (2) Connect to Mozilla-G, stay in wifi settings
   (3) Wait for 5 minuts
   (4) Wake up otoro/uangi
   (5) Use browser to open google
2. With settings app opened, in main settings page
   (1) Unplug USB
   (2) Connect to Mozilla-G, return to main settings after connected
   (3) Wait for 5 minuts
   (4) Wake up otoro/uangi
   (5) Use browser to open google
3. With settings app closed
   (1) Unplug USB
   (2) Connect to Mozilla-G, close settings app after connected
   (3) Wait for 5 minuts
   (4) Wake up otoro/uangi
   (5) wait for status bar shows connected
   (6) open settings app
   (7) Use browser to open google

Result:
1. Upon phone wake up, the wifi status icon in status bar shows from no-connection, connecting, to connected in three cases.
   So wifi is disconnected while sleep and reconnected after wake up.
2. Connection status in settings app shows "Connected to Mozilla-G" in three cases, no "connecting to null" is shown.
2. Browser opens google correctly in three cases.

Remark:
1. I uses engineer build, I assume it behaves same as release build.
2. I didn't test WEP and WPA-PSK, the behavior should be the same.


Lawrence, if you can still reproduce with nightly build I use, please provide more detail about your wifi configuration(like security mode, hide ssid, etc.) and reproduce step. It's would be better if you can provide logcat and your wifi settings(located in /data/misc/wifi/wpa_supplicant.conf, you can remove your identity/password in it before uploading).
One note about providing logcats (especially if you can reproduce this at will): there's a developer setting to show wifi output in adb that is immensely useful in tracking down problems.
I can no longer reproduce this issue with the 20121206062128 stable build.
You need to log in before you can comment on or make changes to this bug.