Clicks around edge of jewel buttons only depress the button and drag the window

VERIFIED FIXED

Status

()

Firefox
SocialAPI
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: MattN, Unassigned)

Tracking

({ux-userfeedback})

Trunk
All
Mac OS X
ux-userfeedback
Points:
---

Firefox Tracking Flags

(firefox17 wontfix, firefox18 wontfix, firefox19 wontfix, firefox21 wontfix, firefox22 verified, firefox23 verified)

Details

Attachments

(1 attachment)

Created attachment 676455 [details]
Screencast on OS X 10.7

While trying to click on the jewels, I accidentally dragged my Firefox window twice in a short time.  After further investigation, I realized that clicks near the edges of social provider jewel buttons, also act like clicks in the titlebar and allow dragging the window.  My regular clicks were accidentally triggering the drag as well.  See the screencast of the problem on OS X.

Reproducible: Always
Matthew, what versions of Firefox does this affect? Is this in the 17.0 Beta?
I just reproduced the problem on the latest beta.
status-firefox17: --- → affected
status-firefox18: --- → affected
status-firefox19: --- → affected
This is now even worse because the panels don't open anymore when clicking on the left and right sides of the buttons (even though the depressed state of the button is shown). The perceived clickable area doesn't match reality.
Severity: minor → normal
status-firefox22: --- → affected
Keywords: ux-userfeedback
Summary: Clicks around edge of jewel buttons can also drag the window → Clicks around edge of jewel buttons only depress the button and drag the window
FTR, I can't repro on Windows.  While looking at bug 854497 on OSX, I noticed some differences between Windows and OSX wrt margins/padding etc of the toolbar stuff.  Also interestingly, if you install a theme and see the problem in bug 854497, the "draggable" area is the area within the "borders" that erroneously appear.  So these 2 bugs seem related...
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855389
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
status-firefox17: affected → wontfix
status-firefox18: affected → wontfix
status-firefox19: affected → wontfix
status-firefox21: --- → wontfix
status-firefox23: --- → fixed
I can still reproduce this in Firefox Nightly 23.0a1 2013-04-11 though the dragable zone is smaller. In an older Nightly I can click and drag from about 3 or 4 pixels inside the button (not sure exactly), whereas in the latest Nightly I can only do so within 1 pixel. The window should only be draggable from border +1px I think.
Shane let me know that all toolbar buttons allow dragging the window on the 1px edge so marking this verified fixed for Firefox 23.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-firefox23: fixed → verified
Resolution: --- → FIXED
Marking this bug fixed for Firefox 22 based on bug 855389 comment 20. I will verify this with tomorrow's Aurora build.
status-firefox22: affected → fixed
Verified fixed in Firefox 22.0a2 2013-04-12.
Status: RESOLVED → VERIFIED
status-firefox22: fixed → verified
You need to log in before you can comment on or make changes to this bug.