Toolbar button border too tight

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
20 years ago
17 years ago

People

(Reporter: edwin, Assigned: talisman)

Tracking

Details

(Reporter)

Description

20 years ago
The raised border around the toolbar icons is too tight. A part of the icon
sometimes disappears and also the text gets changed from 'New Msg' to 'New M..'
because there is not enough space.

Two screenshots are available (sorry for the low quality, but the only program I
had available was MS Photopaint):

http://www.djo.nl/grendel/border1.gif
http://www.djo.nl/grendel/border2.gif
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

20 years ago
Verified & investigating. I think the problem is in the layout code somewhere.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

20 years ago
Bug was *not* due to ToolBarButton - ToolBarButton only served to make the bug
apparent. Edwin's code in GrendelToolBar was not setting the button size
correctly (Dimension.setSize() is not for setting Component sizes). I fixed the
code block which sets the button size and the problem of the border clipping the
text is no more.

Updated

20 years ago
Target Milestone: M7

Updated

20 years ago
Target Milestone: M7

Comment 3

20 years ago
Put back to Blank milestone from M7.  Sorry.
You need to log in before you can comment on or make changes to this bug.