update compare.py to use datazilla

RESOLVED DUPLICATE of bug 864430

Status

Testing
Talos
RESOLVED DUPLICATE of bug 864430
6 years ago
5 years ago

People

(Reporter: jmaher, Assigned: jmaher)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
now that datazilla is live and healthy, it is time to start using it.  First step is to update compare.py to use the referenced revision and compare the graph server data side by side.
(Assignee)

Comment 1

6 years ago
Created attachment 676579 [details] [diff] [review]
access datazilla for a changeset in addition to graph server (0.9)

as per the work done at our meetup in Toronto, I figured this should be placed on a bug.  I did some work on this yesterday to clean it up and it is looking pretty good.  We can actually differentiate between pgo and non pgo now (for dz only).  

I would like to fix this up to use results.py to get accurate reporting on the data I am collecting.  Also have better stats about what inaccuracies or differences we see.
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
(Assignee)

Comment 2

6 years ago
Here is an example of what the output looks like with the above patch:
Linux:
    tdhtmlr: 425.588 -> 444.618; 433.941.   [438.051470588] [PGO: 386.625]
    tresize: 13.0 -> 50.0; 13.0.   [13.9163954983] [PGO: 10.875839299]
    tdhtmlr_nochrome: 411.941 -> 420.618; 419.324.   [419.225490196] [PGO: 385.534313725]
    tspaint_places_med: 680.474 -> 717.789; 681.421.   [694.583732057] [PGO: 613.684210526]
    tspaint_places_max: 689.789 -> 758.368; 691.737.   [880.157894737] [PGO: 815.081339713]
    kraken: 3841.7 -> 3995.2; 3861.5.   [256.794871795] [PGO: 255.068376068]
    sunspider: 363.0 -> 372.4; 368.6.   [12.96] [PGO: 11.52]
    v8: 5769.25 -> 6100.78; 5849.53.   [0.0] [PGO: 0.0]
    dromaeo_css: 2076.96 -> 2158.99; 2119.74.   [3462.24918013] [PGO: 4201.57820614]
    dromaeo_dom: 141.427 -> 152.707; 151.52.   [166.786999777] [PGO: 227.045774493]
    tscrollr: 10049.4 -> 17496.1; 10050.6.   [10057.5083333] [PGO: 10052.0083333]
    a11yr: 519.0 -> 596.0; 521.0.   [524.208333333] [PGO: 376.458333333]
    ts_paint: 686.579 -> 796.895; 695.737.   [712.459330144] [PGO: 623.358851675]
    tpaint: 201.0 -> 303.0; 216.0.   [227.578947368] [PGO: 185.052631579]
    tsvgr: 2811.4 -> 4050.36; 4013.32.   [3961.37121212] [PGO: 3921.50757576]
    tsvgr_opacity: 94.0 -> 101.5; 94.0.   [94.875] [PGO: 72.5416666667]
    tp5n: 363.182 -> 374.803; 367.157.   [372.021043771] [PGO: 289.462962963]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 864430
You need to log in before you can comment on or make changes to this bug.