After adjusting margins, Reader Mode toolbar cannot be triggered in both orientations

RESOLVED WORKSFORME

Status

()

Firefox for Android
Reader View
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: xti, Assigned: lucasr)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox17 affected, firefox18 affected, firefox19 affected, fennec+)

Details

(Reporter)

Description

5 years ago
Firefox 19.0a1 (2012-10-29)
Device: Galaxy R
OS: Android 2.3.4

Steps to reproduce:
1. Go to news.google.com and open any news
2. After the new page is completely loaded, tap on Reader Mode button from URL Bar
3. Tap on screen for Reader Mode toolbar
4. Decrease the margin limit to min
5. Switch device to landscape and scroll down the page
6. Tap on screen to trigger the Reader Mode toolbar

Expected result:
The Reader Mode toolbar is triggered.

Actual result:
The Reader Mode toolbar cannot be triggered at all.
In console the same error occurs each time when I perform step 6:

E/GeckoPanZoomController(13790): Received impossible touch end while in WAITING_LISTENERS
E/GeckoPanZoomController(13790): Received impossible touch end while in WAITING_LISTENERS
E/GeckoPanZoomController(13790): Received impossible touch end while in WAITING_LISTENERS
I too am able to reproduce this, Nightly (10/30), Samsung Galaxy Nexus.

I used the URL: http://www.cbsnews.com/8301-201_162-57542332/superstorm-sandy-slams-east-coast-leaving-floods-millions-without-power/

Step #4, I increased the margins (+) to get a narrow article, and on both orientations afterwards I was unable to trigger the toolbar.

(A) Is this a regression
(B) Are all channels affected here?
tracking-fennec: --- → ?
status-firefox19: --- → affected
Summary: Reader Mode toolbar cannot be triggered in landscape → Reader Mode toolbar cannot be triggered in landscape after adjusting margins

Updated

5 years ago
Summary: Reader Mode toolbar cannot be triggered in landscape after adjusting margins → After adjusting margins, Reader Mode toolbar cannot be triggered in both orientations
(Reporter)

Comment 2

5 years ago
The latest Aurora and Beta builds are affected too
status-firefox17: --- → affected
status-firefox18: --- → affected
Lucas, able to reproduce?
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 18+
(Assignee)

Comment 4

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #3)
> Lucas, able to reproduce?

Nope. Do you dismiss the style popup before switching to landscape?
tracking-fennec: 18+ → ?
I'm not able to reproduce anymore. WFM?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

5 years ago
(In reply to Lucas Rocha (:lucasr) from comment #4)
> (In reply to Aaron Train [:aaronmt] from comment #3)
> > Lucas, able to reproduce?
> 
> Nope. Do you dismiss the style popup before switching to landscape?

It doesn't matter if the style popup is not dismissed before switching to landscape, because it will be auto dismissed when scrolling down to the bottom of the page.

(In reply to Aaron Train [:aaronmt] from comment #5)
> I'm not able to reproduce anymore. WFM?

I am still able to reproduce it on the latest Nightly.

--
Firefox 19.0a1 (2012-11-06)
Device: Galaxy S2
OS: Android 4.0.3
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
tracking-fennec: ? → 18+
(Assignee)

Comment 7

5 years ago
Hey Cristian, any chance you could record a short video showing how you reproduce this bug?
(Assignee)

Comment 8

5 years ago
I'm fairly sure this not specific to reader mode. The toolbar is just a fixed element positioned at the bottom of the window. This should be working flawlessly. Kats, Chris, any clues?
(Reporter)

Comment 9

5 years ago
(In reply to Lucas Rocha (:lucasr) from comment #7)
> Hey Cristian, any chance you could record a short video showing how you
> reproduce this bug?

I cannot reproduce it right now due to bug 811231 (for step 4. I will upload a video when it will be fixed.
tracking-fennec: 18+ → +
(Assignee)

Comment 10

5 years ago
(In reply to Cristian Nicolae (:xti) from comment #9)
> (In reply to Lucas Rocha (:lucasr) from comment #7)
> > Hey Cristian, any chance you could record a short video showing how you
> > reproduce this bug?
> 
> I cannot reproduce it right now due to bug 811231 (for step 4. I will upload
> a video when it will be fixed.

Now that bug 811231 is fixed, could you please upload a video with steps to reproduce?
(Reporter)

Comment 11

5 years ago
(In reply to Lucas Rocha (:lucasr) from comment #10)
> 
> Now that bug 811231 is fixed, could you please upload a video with steps to
> reproduce?

I tried to reproduce it on the latest Nightly and the toolbar is triggered each time when I tap on screen, no matter what layout settings are changed. I will close this issue as WFM for now and I will reopen it if I will be able to reproduce it again (adding a video too in this case).

--
Firefox 20.0a1 (2012-11-21)
Device: Galaxy S2
OS: Android 4.0.3
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.