The default bug view has changed. See this FAQ.

Option to remove dupe errors/warnings in Error Console

RESOLVED WONTFIX

Status

Toolkit Graveyard
Error Console
--
enhancement
RESOLVED WONTFIX
16 years ago
9 months ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

Details

(Reporter)

Description

16 years ago
I'd like to be able to hide the same error from being shown twize. So if you
have two same warnings the console would only show it once.
Something like "View" -> "Remove duplicate warnings" -> On/Off
(Reporter)

Updated

16 years ago
Summary: option to show only uniq errors → option to remove dupe errors/warnings in JavaScript console
(Reporter)

Comment 1

16 years ago
try adding:
user_pref("javascript.options.strict", true);
to your prefs.js file and go to:
http://bugzilla.mozilla.org/query.cgi

the console is flooded with dupe warnings....

Comment 2

16 years ago
-> hewitt
Assignee: pchen → hewitt

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Component: XP Apps → JavaScript Console
QA Contact: sairuh → jrgm

Comment 3

15 years ago
<OT>BTW is there any GUI to switch javascript.options.strict or it's just
accessible via pref.js?</OT>
(Reporter)

Comment 4

15 years ago
edit -> prefs -> debug
May be Severity should be reduced from Normal to Enhancement ?

Updated

13 years ago
Severity: normal → enhancement

Updated

11 years ago
Summary: option to remove dupe errors/warnings in JavaScript console → Option to remove dupe errors/warnings in Error Console
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: hewitt → nobody
Status: ASSIGNED → NEW
QA Contact: jrgmorrison → error-console
Target Milestone: Future → ---
Moving this to Toolkit, I'll get to this after bug 489736 lands (if toolkit wants it).
Component: Error Console → Error Console
Product: SeaMonkey → Toolkit
QA Contact: error-console → error.console
Depends on: 490886

Updated

8 years ago
Blocks: 490886
No longer depends on: 490886

Updated

7 years ago
Duplicate of this bug: 147015
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX

Comment 9

9 months ago
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
The Error Console feature was removed entirely from the tree in Bug 1278368 and the bugzilla component is now being removed. We’ve migrated bugs that seem to also affect the Browser Console into the devtools component, please move this over if it was missed.
Status: REOPENED → RESOLVED
Last Resolved: 9 months ago9 months ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
(Assignee)

Updated

9 months ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.