Closed Bug 807164 Opened 12 years ago Closed 12 years ago

[socorro-crashstats] Links to advanced search is broken with version=ALL on /query

Categories

(Socorro :: Webapp, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: adrian, Assigned: adrian)

References

Details

Steps to reproduce
------------------

1. Go to advanced search
2. Select product=Fennec, version=All, then run search
3. Click the advanced search link on top right of the page
4. A 404 is raised, because the link has an invalid version: "Fennec:ALL"

Expected
--------

The link to advanced search does not set the version parameter.
Commits pushed to master at https://github.com/mozilla/socorro-crashstats

https://github.com/mozilla/socorro-crashstats/commit/da4a2f36badb0cc61644a4edd1b6b1e8571580f1
Fixes bug 807164 - Fixed link to search when version is ALL.

https://github.com/mozilla/socorro-crashstats/commit/ba79c47eadf65270b943dd50303ab0310cf16c40
Merge pull request #266 from AdrianGaudebert/807164-search-link-on-query

Fixes bug 807164 - Fixed link to search when version is ALL.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.