[Task Manager] Snapshot in card view has a vertical offset

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Window Mgmt
P3
normal
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: kanru, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 676936 [details]
Cardview of the camera app

Bottom of the snapshot is cropped.
Looks like an issue about taking snapshot of fullscreen app.
Android's Task Manager just cut the screenshot to match a square, so this may be a UX decision.
(Reporter)

Comment 3

5 years ago
Created attachment 676949 [details]
Cardview of the video app

Looks like so. Another fullscreen app has the same issue.

Note that this effect also makes the opening transition first display the cropped image then the correctly rendered app; it makes a "jump" feeling.

Updated

5 years ago
Component: Gaia → Gaia::Homescreen

Updated

5 years ago
Component: Gaia::Homescreen → Gaia::System
Priority: -- → P3
Summary: [homescreen][card view] Snapshot in card view has a vertical offset → [Task Manager] Snapshot in card view has a vertical offset

Updated

4 years ago
Component: Gaia::System → Gaia::System::Window Mgmt
Cant reproduce in 2.1 or master
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.