Changing from https to http doesn't work once the URL was accessed. Auto-complete function keeps changing it to https.

RESOLVED DUPLICATE of bug 781617

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 781617
6 years ago
6 years ago

People

(Reporter: Pieter Jordaan, Unassigned)

Tracking

16 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I configured a new web server on https, and then decided to change it to http.

Auto complete keeps changing the url to https, even after using the 'Del' key to remove all traces of it from the auto-complete list. When I press enter, it tries to open the https one again.
The fact that it hides the 'http://' part for normal http URLS makes it even more difficult, as you don't know where it is connecting. I even restarted firefox.
When I copy the URL from Internet explorer, then paste it in firefox it also changes it to https.

To fix it, I added /index.php to the end, so that it creates a new auto-complete entry for it, but I still can not access it without the /index.php when typing it out.
(Reporter)

Updated

6 years ago
Version: unspecified → 16 Branch
(Reporter)

Comment 1

6 years ago
I saw this problem on previous branches as well, but only really got annoyed with it now.

I would really like to see the http:// and https:// bit returned to the URL, although that would not fix the current problem.
Try searching for the https entry in history, and remove it from there.
The behavior is "fixed" in Firefox 17 in the sense you can type http and go to the http version.
For any remaining issues you can refer to bug 769994.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781617
Duplicate of this bug: 807290
You need to log in before you can comment on or make changes to this bug.