[Phone] Final Ringtones Need to be Added to the Build

VERIFIED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: patryk, Assigned: vingtetun)

Tracking

unspecified
B2G C3 (12dec-1jan)
All
Other
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: visual design sound UX-P1)

Attachments

(4 attachments, 2 obsolete attachments)

Comment hidden (empty)
(Reporter)

Comment 1

5 years ago
Finalized ringtones need to be added to builds.
blocking-basecamp: --- → ?
Keywords: polish
Summary: [Phone → [Phone] Final Ringtones Need to be Added to the Build
(Reporter)

Comment 2

5 years ago
Also these address the bug that the current OGG ringtones may not play as they are over 48khz.
(Reporter)

Updated

5 years ago
See Also: → bug 800235
(Reporter)

Comment 3

5 years ago
https://github.com/mozilla-b2g/gaia/pull/6140
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
This made builds too large to flash onto phones so I had to back it out

https://github.com/mozilla-b2g/gaia/commit/62df14acb9a00979b8ab87d4872d33ca7e942f1c

See bug 807851.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
From bug 807851

Overweight apps are

16M	./webapps/keyboard.gaiamobile.org
11M	./webapps/sms.gaiamobile.org
10M	./webapps/settings.gaiamobile.org
11M	./webapps/communications.gaiamobile.org

Two problems
 - many of these ringtones are HUGE.  One is almost 3MB.
 - they seemed to be copied verbatim into three different locations

Questions
 - why are the ringtones so huge?
 - why are they copied into three locations?
 - why does SMS have ringtones?
 - can we store them on the SD card?

Comment 6

5 years ago
we do need these ringtones but need to make sure they're proper format and placed in the right structure.  :timdream can you make sure this is owned by someone in your team please?
Assignee: padamczyk → timdream+bugs
blocking-basecamp: ? → +
Priority: -- → P3
(Reporter)

Comment 7

5 years ago
It appears that if an app is using an asset it needs to be placed within that app, I followed how they were coded initially and just did an asset swap. 

A few months ago I advocated for 1 common resource library, but it was out of scope for v.1. Would be great if we could add that in.

A few ringtones are long, as they are a tune.
1. What should happen, is that settings shouldn't require a copy of the ringtones and notifications.

2. There should be a common folder for audio. Where the ringtones and notifications sit. I am okay with them being on the SD Card.
Some of the ringtones were encoded at over 200 kbps, which is excessive for something normally played out of a phone speaker.

The should certainly be shared, but if you give me the originals, patryk, I can find more optimal settings for them.
(In reply to Faramarz (:faramarz) from comment #6)
> we do need these ringtones but need to make sure they're proper format and
> placed in the right structure.  :timdream can you make sure this is owned by
> someone in your team please?

Rex, can you take this?
Assignee: timdream+bugs → rexboy
(Reporter)

Comment 10

5 years ago
(In reply to Ralph Giles (:rillian) from comment #8)
> Some of the ringtones were encoded at over 200 kbps, which is excessive for
> something normally played out of a phone speaker.
> 
> The should certainly be shared, but if you give me the originals, patryk, I
> can find more optimal settings for them.

We still need to optimize them (bring them down in size), but they also need to start being beta tested (b2g test drivers), and any audio tweaks made if necessary and then optimized. Realistically people will be using mp3s at high bitrates as ringtones as well so these would be a good stress.

I will provide smaller ringtones later in the week.

Updated

5 years ago
Blocks: 797140
(Reporter)

Comment 11

5 years ago
(In reply to Ralph Giles (:rillian) from comment #8)
> Some of the ringtones were encoded at over 200 kbps, which is excessive for
> something normally played out of a phone speaker.
> 
> The should certainly be shared, but if you give me the originals, patryk, I
> can find more optimal settings for them.

Hey Ralph, here are the WAVs https://www.dropbox.com/sh/jwbzgka6v633i1q/Dz06fKq0eu the OGG files are encoded in VBR, the vendor has done work in various mobile platforms before and has optimized them for the phone speaker, however he believes that going below 160kps will create noticeable digital artifacts. I can get him to re-tune some of the files, but if you can work your magic and compress them further without impacting the quality, please try. 

And yes, the phone speaker can be poor, but many phone today have great speakers, there are also docks and headphones, so I'd want them to sound decent with all outputs.
(Reporter)

Comment 12

5 years ago
Created attachment 678516 [details]
Default Ringtone & Notifier
(Reporter)

Comment 13

5 years ago
I added the default ringtone (Classic Courier) and notifier (Exclamation). Can you please add these into the builds. The rest of the ringtones / notifications should be loaded onto the SD card but should not be read/previewed in the MUSIC app.
Chris,

About overweight apps, I think we can reduce the keyboard size if we take out the Japanese input method. It has a huge JSON dictionary. But we need to put in other european dictionaries, so that won't free up much space overall.

More relevant to this bug: how in the world can the set of built-in ringtone options be stored on the sdcard? We don't have any installation or update mechanism for that do we? Are the phones going to be manufactured and sold with an sdcard pre-installed with ringtones on it?  What if the user upgrades to a bigger card? They lose their ring tones? And the relevant apps are presumably written to use URLs for loading the ringtones, not device storage. And making the music app not play ringtones is another wrinkle

I can't imagine any way that sd card storage makes sense for these files. Maybe I'm missing something big, but I'd say that the sd card is not an option here.
Before we get too deep into this, maybe someone can answer the questions in comment 5?
Please handle the overall oversizing issue in another bug, in the main time:

(In reply to Chris Jones [:cjones] [:warhammer] from comment #15)
> Before we get too deep into this, maybe someone can answer the questions in
> comment 5?

(In reply to Chris Jones [:cjones] [:warhammer] from comment #5)
> Two problems
>  - many of these ringtones are HUGE.  One is almost 3MB.
>  - they seemed to be copied verbatim into three different locations
> 
> Questions
>  - why are the ringtones so huge?

I guess bug 704993 prevent us from choosing sensible bit rate?

>  - why are they copied into three locations?

Because they all need to play the tone in their pickers (or sound the actual alarm/notification)

>  - why does SMS have ringtones?

New SMS notification is sound by SMS app itself

>  - can we store them on the SD card?

We could put the sound into device storage; but the v1 production requirement doesn't require that, and brings other issues (Do we want to distinguish ringtones vs music? How? How should sound picker works?)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #16)

> >  - why are the ringtones so huge?
> 
> I guess bug 704993 prevent us from choosing sensible bit rate?

No, the effect is the other direction: the work-around for bug 704993 makes the files smaller. :)

The files are large because we want to support high quality output, as per comment #11, and some of the files are tens of seconds long. Although the files patryk posted are all mono, which helps quite a bit.
(In reply to Patryk Adamczyk [:patryk] UX from comment #11)

> https://www.dropbox.com/sh/jwbzgka6v633i1q/Dz06fKq0eu

Thanks for posting lossless versions. There are a lot of files, so hand tuning each one would take a few days. However, as a baseline here's the set run through oggenc with the default -q 3, which comes to 4.8 MB altogether. That's still a considerable improvement.

  http://people.mozilla.org/~rgiles/2012/ringtones_48kHz_mono_ogg.zip

I did spot checks on about 20% of the encodes with my good headphones, and they were all transparent to me. Bitrates vary between 40 and 150 kbps, depending on the content, which seems about right for mostly-simple, mono ogg.
(Reporter)

Updated

5 years ago
Blocks: 809680
(Reporter)

Comment 19

5 years ago
Talked to Chris Jones, and I'll resubmit the optimized ringtones / notifications when they are ready. Thanks for Ralph it should reduce them by 60% in size, which will not break the build.

Since we don't have a the SD card as part of the v1 production requirement, we'll opt to store them on device.
(Reporter)

Comment 20

5 years ago
I'll also get Chris Jone to merge my commit, so he can scrutinize it for stability.
Assignee: rexboy → padamczyk
How are things going, Patryk?
Flags: needinfo?(padamczyk)
I got busy with other things, so I haven't gotten the optimized opus versions to Patryk. He should have them by the weekend.

Comment 23

5 years ago
Removing the needinfo.
Flags: needinfo?(padamczyk)

Comment 24

5 years ago
Assigning to rillian for now, because he has the next step.
Assignee: padamczyk → giles
(Reporter)

Updated

5 years ago
Whiteboard: visual design → visual design sound ptrack
Created attachment 687305 [details]
compressed tones, bins 1-3

Patryk, here are optimized versions of your first three bins, totaling 2.4 MB on disk.

These are minimum-bitrate encodes as opus or ogg, whichever gave the best results. They're based on informal comparison against the original. If necessary I could save several more 100KB while still sounding good to anyone not directly comparing with the original.
(Reporter)

Comment 26

5 years ago
Created attachment 687315 [details]
FInal Compressed Sounds from Ralph

Attached are the final compressed sounds... there a LARGE savings. Can you please add the ringtones and notification sounds to the settings panel. There is also an opportunity to replace the sounds in the alarm clock to save space.

Attached in the zip is an HTML file with all the names which the user should see... in the notification selection menu the user should see "notifier_exclamation.ogg" displayed as "Exclamation"

The default notification sound should be "Bell" and the default ringer should be "Classic Courier"

Also if anyone ever needs sounds they can be grabbed from here: https://www.dropbox.com/sh/bczd91l9e0xilr9/Ro6L3ydODJ
Attachment #678516 - Attachment is obsolete: true
Attachment #687305 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
Assignee: giles → rexboy

Updated

5 years ago
Priority: P3 → P1
Target Milestone: --- → B2G C2 (20nov-10dec)
Assigning to Kaze since we have plans to have a custom/ folder and a shared place for those ringtones and this will part of it.
Assignee: rexboy → kaze
(Reporter)

Updated

5 years ago
Whiteboard: visual design sound ptrack → visual design sound ptrack UX-P1
(In reply to Vivien Nicolas (:vingtetun) from comment #28)
> Created attachment 688925 [details] [diff] [review]
> Patch

On my local branch I have also fix a small regression I have found with the clock app.
Assignee: kaze → 21
Comment on attachment 688925 [details] [diff] [review]
Patch

Looks fine to me, please open a PR including all media files — or merge this patch yourself. ;-)
Attachment #688925 - Flags: review?(kaze) → review+
https://github.com/mozilla-b2g/gaia/commit/9b2cdf4c25dfc1da496d22a0328b6af24307008e
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Created attachment 689693 [details] [diff] [review]
follow-up

Just fixing a small diff mistake.
Attachment #689693 - Flags: review?(21)
Comment on attachment 689693 [details] [diff] [review]
follow-up

Sigh. thanks!
Attachment #689693 - Flags: review?(21) → review+
Depends on: 820277
(Reporter)

Comment 35

5 years ago
I am re-opening this bug, as yes, the final ringtones have been added, but the the default tones are incorrect, not sure how that was missed as its part of comment 26 (same comment that added the final tones).

Currently the default ringer is: "Classic Prism", and notification is "Ring"

The ringer should be: "Classic Courier" and the notification should be "Bell"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 36

5 years ago
I am re-opening this bug, and yes, the final ringtones have been added, but the the default tones are incorrect, not sure how that was missed as its part of comment 26 (same comment that added the final tones).

Currently the default ringer is: "Classic Prism", and notification is "Ring"

The ringer should be: "Classic Courier" and the notification should be "Bell"

Updated

5 years ago
Target Milestone: B2G C2 (20nov-10dec) → B2G C3 (12dec-1jan)
Created attachment 692962 [details] [diff] [review]
Followup
Attachment #692962 - Flags: review?(poirot.alex)
Comment on attachment 692962 [details] [diff] [review]
Followup

Tested, works fine.
Attachment #692962 - Flags: review?(poirot.alex) → review+
https://github.com/mozilla-b2g/gaia/commit/74f6107ad865102abdecd7d130be891298dec42a
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
vivien, how can i test this patch?  on the 1-2 build, i see both classic prism and classic courier options in the sound settings.

Comment 41

5 years ago
Fix verified on 1-3 build

Unagi Build ID:20130103070201 - default settings: the ringer "Classic Courier" and the notification "Bell"
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
Whiteboard: visual design sound ptrack UX-P1 → visual design sound UX-P1
Duplicate of this bug: 821127
You need to log in before you can comment on or make changes to this bug.