segmentation fault with invalid http password

VERIFIED FIXED

Status

()

Core
Networking: HTTP
--
critical
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: Joel Becker, Assigned: neeti)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.19pre15-raid-kdb-ext3-nic i586)
BuildID:    2001051408

If you travel to a site that uses HTTP authentication and enter an invalid
password mozilla segfaults.  If a correct password is entered, it works just
fine.

Reproducible: Always
Steps to Reproduce:
1. Put in the URL of a page requiring HTTP authentication
2. Purposely mistype your username or password
3. Watch it segv

Actual Results:  Segmentation Violation, Core-dumped Blues

Expected Results:  Poped up an error dialog.

Updated

17 years ago
Keywords: crash

Comment 1

17 years ago
qa to me.

I'll try to reproduce it 
QA Contact: tever → benc

Comment 2

17 years ago
Works for me on linux build 2001053108.

Comment 3

17 years ago
Joel,

Please try a newer build, this is WFM on the commercial side of the same build
Chris used...
(Reporter)

Comment 4

17 years ago
Works for me on 2001060508 for linux.  I note that it does not say 'bad login',
just prompts me again.  This is a design issue, not necessarily a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
It won't display the error page HTML that your server sends until you hit cancel.

That's consistent with communicator 4.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.