Closed Bug 807527 Opened 9 years ago Closed 7 years ago

JägerMonkey Regression on misc-basic-emptyloop & misc-basic-array & misc-basic-intops (oct 27)

Categories

(Core :: JavaScript Engine, defect)

19 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: nbp, Unassigned)

References

Details

Regression reported by AWFY:
misc-basic-array: from 127ms to 155ms
misc-basic-emptyloop: from 58ms to 103ms (*)

The regression appears for JM only.  The regression appeared between changesets a39913319ce6 and e4204b2b987c, which only includes Bug 804636 part 1 among the changes made to the JS engine.

* last time I investigated this test JM was faster because the code it produced was small enough to stay in the instruction cache of the CPU, even if a write at the same location was inside the loop.  So I would not worry much about this test case, but the faulty patch is likely adding something to the generated code of loops.
misc-basic-intops: from 350ms to 388ms
Summary: JägerMonkey Regression on misc-basic-emptyloop & misc-basic-array (oct 27) → JägerMonkey Regression on misc-basic-emptyloop & misc-basic-array & misc-basic-intops (oct 27)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.