suggesting a better sites permission system.

RESOLVED DUPLICATE of bug 38966

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 38966
17 years ago
14 years ago

People

(Reporter: Chu Alan, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050515

it is better to have a new sites permission system(or manager ?) that will
integrate the cookie manager and image manager (or possibly other managers also).

In this new system, sites will be grouped into site groups, and one can apply
policies on each group of site, for example, we have two groups of sites (one
can add, delete and name a group of site) :-

[ trusted sites ]
< permisssions : can set cookies, can load images, etc. >
http://www.mozilla.org/
http://www.google.com/

[ image-heavy sites ]
< permisssions : cannot set cookies, cannot load images, etc. >
http://www.images.com/
http://www.manyimages.com/
http://www.manymanyimages.com/

here we have two groups of sites, each group of sites has its own permission box
to be filled in, including cookies and images permission, so that we can add or
modify site permission in a faster way, without going through all sites and
change them all.

Even better, one can use wild cards (or even regular expressions ?) to match
site names to apply policies, for example :-

[ bad sites ]
http://www.*bad*.com

using this system will provide more flexibility to both users and developers.


Reproducible: Always
Steps to Reproduce:
1.Edit|perferences
2.advanced|cookies or advanced|images
3.
see bug 38966 and bug 43501

*** This bug has been marked as a duplicate of 38966 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.