JavaScript timer based window.print() function conflicts with command-P function resulting in dialog interaction conflict

RESOLVED DUPLICATE of bug 476541

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 476541
6 years ago
6 years ago

People

(Reporter: Fred Muhlenberg, Unassigned)

Tracking

16 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 677263 [details]
Screen shot of error.  Page Javascript sample

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Firefox configured to open windows in a new tab.

Steps to reproduce

Visit: http://www.scouting.org/scoutsource/CubScouts/CubScouts/UniformsAndAwards/sanda.aspx

Select a belt loop.  I chose chess.
Click the print icon on the page.
A new page is displayed in a new tab.
Execute a "command-P" within 5 seconds and the Print dialog is displayed
Wait 5 seconds.



Actual results:

A Printer Error alert is displayed. 
Now, I am unable to cancel from Print dialog or Printer alert. The window focus is also captured so I cannot delete the page or quit Firefox from keyboard or mouse interactions.

Alternate (no error) scenario:
If I wait patiently for 5 seconds and do not execute a "command-P", the Print dialog is displayed and no Printer Error alert.



Expected results:

The Printer Error alert should not be displayed once the Print Dialog is active.
See attached file for screen shot.

Comment 1

6 years ago
WFM on Win 7 with FF16. Maybe it's OSX-specific.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.